summaryrefslogtreecommitdiff
path: root/user/phonon
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-29 05:20:27 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-29 05:20:27 -0500
commitf314943ac0343e9c99cfde49b0ea8ed481fa3610 (patch)
tree51e5b7175aa4302bb617e0535d80f0311632901a /user/phonon
parent8ed33aa6c0254675d5854372bc47e15cf45d8c7d (diff)
downloadpackages-f314943ac0343e9c99cfde49b0ea8ed481fa3610.tar.gz
packages-f314943ac0343e9c99cfde49b0ea8ed481fa3610.tar.bz2
packages-f314943ac0343e9c99cfde49b0ea8ed481fa3610.tar.xz
packages-f314943ac0343e9c99cfde49b0ea8ed481fa3610.zip
user/phonon: new package
Diffstat (limited to 'user/phonon')
-rw-r--r--user/phonon/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/user/phonon/APKBUILD b/user/phonon/APKBUILD
new file mode 100644
index 000000000..07d91d7d5
--- /dev/null
+++ b/user/phonon/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=phonon
+pkgver=4.9.1
+pkgrel=0
+pkgdesc="Qt library for playing multimedia files"
+url="https://phonon.kde.org/"
+arch="all"
+license="LGPL-2.1"
+depends=""
+makedepends="cmake extra-cmake-modules pulseaudio-dev
+ qt5-qtbase-dev qt5-qttools-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-designer"
+source="http://download.kde.org/stable/phonon/$pkgver/phonon-$pkgver.tar.xz"
+builddir="$srcdir/phonon-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=TRUE \
+ -DWITH_GLIB2=TRUE \
+ -DWITH_PulseAudio=TRUE \
+ -DPHONON_BUILD_PHONON4QT5=TRUE \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+designer() {
+ pkgdesc="$pkgdesc (Qt Designer plugin)"
+ install_if="$pkgname=$pkgver-$pkgrel qt5-qttools"
+ mkdir -p "$subpkgdir"/usr/lib/qt5/plugins/
+ mv "$pkgdir"/usr/lib/qt5/plugins/designer \
+ "$subpkgdir"/usr/lib/qt5/plugins/
+ rmdir "$pkgdir"/usr/lib/qt5/plugins || true # Never mind
+}
+
+sha512sums="a1741765071a625d9b9073d9ad1571b91cf5bfce2223bd1b034828d02dc52624587a6ec5352f3702df79f6e4201007596843fbcb9f15c9b489a858200787d728 phonon-4.9.1.tar.xz"