summaryrefslogtreecommitdiff
path: root/user/php7-apcu/APKBUILD
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2018-12-01 06:31:43 -0800
committerzlg <zlg@zlg.space>2018-12-01 06:31:43 -0800
commit7aee7fba78b839e52d01d5234a9bc1e5499c2a89 (patch)
tree732fa012717e7f17a5ba7231700a98cd10a41ad6 /user/php7-apcu/APKBUILD
parentde508fd914f259da2e328baab4a40841ea821e8a (diff)
downloadpackages-7aee7fba78b839e52d01d5234a9bc1e5499c2a89.tar.gz
packages-7aee7fba78b839e52d01d5234a9bc1e5499c2a89.tar.bz2
packages-7aee7fba78b839e52d01d5234a9bc1e5499c2a89.tar.xz
packages-7aee7fba78b839e52d01d5234a9bc1e5499c2a89.zip
user/php7-apcu: new package
Diffstat (limited to 'user/php7-apcu/APKBUILD')
-rw-r--r--user/php7-apcu/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/user/php7-apcu/APKBUILD b/user/php7-apcu/APKBUILD
new file mode 100644
index 000000000..aa487a4e6
--- /dev/null
+++ b/user/php7-apcu/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer:
+pkgname=php7-apcu
+_pkgname=${pkgname#php7-}
+pkgver=5.1.14
+pkgrel=0
+pkgdesc="Userland cache for PHP"
+url="https://github.com/krakjoe/apcu"
+arch="all"
+license="PHP-3.01"
+depends="php7"
+makedepends="php7-dev"
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/krakjoe/${_pkgname}/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-apcu
+ make
+}
+
+check() {
+ cd "$builddir"
+ # The tests have a prompt at the end for sending stats
+ make NO_INTERACTION=1 test
+}
+
+package() {
+ cd "$builddir"
+ # It didn't listen to DESTDIR
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+sha512sums="fe39d46d2905732296a70b79ab0977909c9ff7cb571118f35831e75a9a018edf909992954e39f79cc4710f9fdec93e6067068afea02304345e4ff6babc65a7d0 php7-apcu-5.1.14.tar.gz"