summaryrefslogtreecommitdiff
path: root/user/php7/test-fixes.patch
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-25 07:26:01 +0000
committerMax Rees <maxcrees@me.com>2020-04-05 12:22:26 +0000
commit1898956d4fb51404a527e909230781848a9d3118 (patch)
tree809d21e6b0aa650fd626123b63b43b5cf64bf133 /user/php7/test-fixes.patch
parent7f8d4d642ad643f553e0fe74c0d48d59c81d178c (diff)
downloadpackages-1898956d4fb51404a527e909230781848a9d3118.tar.gz
packages-1898956d4fb51404a527e909230781848a9d3118.tar.bz2
packages-1898956d4fb51404a527e909230781848a9d3118.tar.xz
packages-1898956d4fb51404a527e909230781848a9d3118.zip
user/php7: bump to 7.4.4
* Use system libgd * Use system oniguruma * Upstream has migrated from pcre to pcre2 * Drop comments about extensions that aren't being built (imap, recode, sodium, tidy) * Drop php7-wddx (has been removed from core upstream) * Drop php7-litespeed (I don't think anyone uses this) * Pin subpackage versions to main package * Fix _extensions_by_load_order so all extensions are tested * This increases the test suite size from ~ 9000 to ~ 15000 * Add additional API/ABI checks from Fedora
Diffstat (limited to 'user/php7/test-fixes.patch')
-rw-r--r--user/php7/test-fixes.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/user/php7/test-fixes.patch b/user/php7/test-fixes.patch
new file mode 100644
index 000000000..976783d77
--- /dev/null
+++ b/user/php7/test-fixes.patch
@@ -0,0 +1,71 @@
+Don't filter out "extension=" settings from INI files during check() so
+we can inject our own module load order.
+
+--- php-7.4.4/build/Makefile.global 2020-03-17 10:40:21.000000000 +0000
++++ php-7.4.4/build/Makefile.global 2020-03-27 06:11:09.713603308 +0000
+@@ -83,7 +83,7 @@ PHP_TEST_SHARED_EXTENSIONS = ` \
+ . $$i; $(top_srcdir)/build/shtool echo -n -- " -d zend_extension=$(top_builddir)/modules/$$dlname"; \
+ done; \
+ fi`
+-PHP_DEPRECATED_DIRECTIVES_REGEX = '^(magic_quotes_(gpc|runtime|sybase)?|(zend_)?extension(_debug)?(_ts)?)[\t\ ]*='
++PHP_DEPRECATED_DIRECTIVES_REGEX = '^(magic_quotes_(gpc|runtime|sybase)?)[\t\ ]*='
+
+ test: all
+ @if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
+
+
+
+
+Likewise, make sure these settings are honored for these tests.
+
+--- php-7.4.4/ext/opcache/tests/php_cli_server.inc 2020-03-17 10:40:23.000000000 +0000
++++ php-7.4.4/ext/opcache/tests/php_cli_server.inc 2020-03-27 22:36:13.054537829 +0000
+@@ -11,7 +11,7 @@ function php_cli_server_start($ini = "")
+ $ini_array = array_map(function($arg) {
+ return trim($arg, '\'"');
+ }, $ini_array);
+- $cmd = [$php_executable, '-t', $doc_root, '-n', ...$ini_array, '-S', PHP_CLI_SERVER_ADDRESS];
++ $cmd = [$php_executable, '-d', 'extension_dir='.ini_get('extension_dir'), '-t', $doc_root, '-n', ...$ini_array, '-S', PHP_CLI_SERVER_ADDRESS];
+ $descriptorspec = array(
+ 0 => STDIN,
+ 1 => STDOUT,
+--- php-7.4.4/ext/session/tests/session_regenerate_id_cookie.phpt 2020-03-17 10:40:28.000000000 +0000
++++ php-7.4.4/ext/session/tests/session_regenerate_id_cookie.phpt 2020-03-27 06:43:24.043633893 +0000
+@@ -56,7 +56,7 @@ var_dump(session_destroy());
+ ob_end_flush();
+ ?>');
+
+-var_dump(`$php -n -d session.name=PHPSESSID $file`);
++var_dump(`$php -c php-check.ini -d session.name=PHPSESSID $file`);
+
+ unlink($file);
+
+--- php-7.4.4/ext/soap/tests/bug73037.phpt 2020-03-17 10:40:24.000000000 +0000
++++ php-7.4.4/ext/soap/tests/bug73037.phpt 2020-03-27 23:02:05.964562383 +0000
+@@ -63,8 +63,7 @@ function get_data($max)
+ }
+
+ $router = "bug73037_server.php";
+-$args = substr(PHP_OS, 0, 3) == 'WIN'
+- ? ["-d", "extension_dir=" . ini_get("extension_dir"), "-d", "extension=php_soap.dll"] : [];
++$args = ["-d", "extension_dir=" . ini_get("extension_dir"), "-d", "extension=soap.so"];
+ $code = <<<'PHP'
+ $s = new SoapServer(NULL, array('uri' => 'http://here'));
+ $s->setObject(new stdclass());
+
+
+
+Don't include useless message on startup which will break every test.
+
+--- php-7.4.4/run-tests.php 2020-03-17 10:40:21.000000000 +0000
++++ php-7.4.4/run-tests.php 2020-03-25 04:01:26.320747990 +0000
+@@ -2503,6 +2503,9 @@ COMMAND $cmd
+ // Does the output match what is expected?
+ $output = preg_replace("/\r\n/", "\n", trim($out));
+
++ // Remove message from built-in development server.
++ $output = preg_replace("/^PHP [0-9.]+ Development Server started at .*\n\n?/m", "", $output);
++
+ /* when using CGI, strip the headers from the output */
+ $headers = array();
+