summaryrefslogtreecommitdiff
path: root/user/php7
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-05 08:32:04 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-05 08:32:04 +0000
commitc23b07fd024be0c9ccc4e1c911cddad9c65251dc (patch)
tree3a57ea616b4f25eb9dfe82cd59c7578ca5c05de8 /user/php7
parent59721a66085b8dd867f8bb1b60afb073827abc4b (diff)
downloadpackages-c23b07fd024be0c9ccc4e1c911cddad9c65251dc.tar.gz
packages-c23b07fd024be0c9ccc4e1c911cddad9c65251dc.tar.bz2
packages-c23b07fd024be0c9ccc4e1c911cddad9c65251dc.tar.xz
packages-c23b07fd024be0c9ccc4e1c911cddad9c65251dc.zip
user/php7: fix PCRE searching
Diffstat (limited to 'user/php7')
-rw-r--r--user/php7/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/user/php7/APKBUILD b/user/php7/APKBUILD
index fa89fcacf..a8ef4976e 100644
--- a/user/php7/APKBUILD
+++ b/user/php7/APKBUILD
@@ -285,7 +285,7 @@ prepare() {
# * Doesn't work with system-provided onigurama, some tests fail (invalid code
# point); probably because bundled onigurama is version 5.x, but we have 6.x.
_build() {
- EXTENSION_DIR=$_extension_dir ./configure \
+ EXTENSION_DIR=$_extension_dir PCRE_INCDIR="/usr/include" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -306,7 +306,7 @@ _build() {
--without-readline \
--enable-libxml \
--with-libxml-dir=/usr \
- --with-pcre-regex=/usr \
+ --with-pcre-regex=/ \
--with-zlib \
--with-zlib-dir=/usr \
$_configure_ext_opts \