summaryrefslogtreecommitdiff
path: root/user/picocom
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2019-03-01 19:23:01 +0100
committerLuis Ressel <aranea@aixah.de>2019-03-01 19:25:34 +0100
commit64a65cee087115e72dd08e0e2a95d517958b033e (patch)
treefbf8745c6246e03062edbad17b742aa0c28df90f /user/picocom
parent54003d7ae7f86ebba107ddad7ea6be0fdcaa6259 (diff)
downloadpackages-64a65cee087115e72dd08e0e2a95d517958b033e.tar.gz
packages-64a65cee087115e72dd08e0e2a95d517958b033e.tar.bz2
packages-64a65cee087115e72dd08e0e2a95d517958b033e.tar.xz
packages-64a65cee087115e72dd08e0e2a95d517958b033e.zip
user/picocom: New package
Diffstat (limited to 'user/picocom')
-rw-r--r--user/picocom/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/picocom/APKBUILD b/user/picocom/APKBUILD
new file mode 100644
index 000000000..274d2e894
--- /dev/null
+++ b/user/picocom/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Luis Ressel <aranea@aixah.de>
+# Maintainer: Luis Ressel <aranea@aixah.de>
+pkgname=picocom
+pkgver=3.1
+pkgrel=0
+pkgdesc="Minimal dumb-terminal emulation program"
+url="https://github.com/npat-efault/picocom"
+arch="all"
+options="!check" # No test suite
+license="BSD-2-Clause AND GPL-2.0+"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/npat-efault/picocom/archive/$pkgver.tar.gz"
+
+build() {
+ # TODO: -DNO_CUSTOM_BAUD can be removed with the next picocom release
+ env CPPFLAGS="$CPPFLAGS -DNO_CUSTOM_BAUD" make
+}
+
+package() {
+ install -m755 -Dt "$pkgdir/usr/bin" pcasc pcxm pcym pczm picocom
+ install -m644 -Dt "$pkgdir/usr/share/man/man1" picocom.1
+}
+
+sha512sums="ff1888494ae0e24a151e19ac3abcdbb499e42eb1abcea401a7c6c3b532be3d64ddd81a511641d1ce0119dc5da3d2804ce8eaff262a9d578bfe8e22fdf6e55ad1 picocom-3.1.tar.gz"