summaryrefslogtreecommitdiff
path: root/user/plasma-integration
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-06 21:34:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-06 21:34:43 -0500
commit074dbcd1613b2300a8399844ce39dc459986f1a5 (patch)
tree2c28a4cde014cdf732c02c69f6e6e9152e5b86c3 /user/plasma-integration
parent5edebe21c05ec53d22c514d85081c47ab0d57751 (diff)
downloadpackages-074dbcd1613b2300a8399844ce39dc459986f1a5.tar.gz
packages-074dbcd1613b2300a8399844ce39dc459986f1a5.tar.bz2
packages-074dbcd1613b2300a8399844ce39dc459986f1a5.tar.xz
packages-074dbcd1613b2300a8399844ce39dc459986f1a5.zip
user/plasma-integration: new package
Diffstat (limited to 'user/plasma-integration')
-rw-r--r--user/plasma-integration/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/user/plasma-integration/APKBUILD b/user/plasma-integration/APKBUILD
new file mode 100644
index 000000000..50afdbc67
--- /dev/null
+++ b/user/plasma-integration/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=plasma-integration
+pkgver=5.8.7
+pkgrel=0
+pkgdesc="Qt platform theme plugin for Plasma"
+url="https://www.kde.org/"
+arch="all"
+license="LGPL-2.1"
+options="!check" # Times out, requires X11 desktop.
+depends="breeze ttf-hack"
+depends_dev="qt5-qtbase-dev qt5-qtx11extras-dev kconfig-dev kconfigwidgets-dev
+ ki18n-dev kiconthemes-dev kio-dev knotifications-dev kwayland-dev
+ kwidgetsaddons-dev kwindowsystem-dev breeze-dev libxcursor-dev"
+makedepends="$depends_dev cmake extra-cmake-modules python3 gettext-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://download.kde.org/stable/plasma/$pkgver/plasma-integration-$pkgver.tar.xz"
+builddir="$srcdir/plasma-integration-$pkgver"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DCMAKE_DISABLE_FIND_PACKAGE_FontNotoSans=true \
+ -DCMAKE_DISABLE_FIND_PACKAGE_FontHack=true \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="04e4528a59f916d9fed8d083b699711df62a504aada40b71607fa10fd51074aae63b163eca2c4893fc07bf86718a567a9047b61874da6eea282993e25bf5c919 plasma-integration-5.8.7.tar.xz"