summaryrefslogtreecommitdiff
path: root/user/plib/shared.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-24 05:56:34 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-24 05:56:34 +0000
commit9474d725ce5d4963229a5223e5c3eec9d4a4052a (patch)
tree930ca12fa18ccd9fc93217138afc9d322585addb /user/plib/shared.patch
parent6fb1b6516a1493d708b0cbad120d6a2bf1251b05 (diff)
downloadpackages-9474d725ce5d4963229a5223e5c3eec9d4a4052a.tar.gz
packages-9474d725ce5d4963229a5223e5c3eec9d4a4052a.tar.bz2
packages-9474d725ce5d4963229a5223e5c3eec9d4a4052a.tar.xz
packages-9474d725ce5d4963229a5223e5c3eec9d4a4052a.zip
user/plib: thanks, Debian
Diffstat (limited to 'user/plib/shared.patch')
-rw-r--r--user/plib/shared.patch288
1 files changed, 288 insertions, 0 deletions
diff --git a/user/plib/shared.patch b/user/plib/shared.patch
new file mode 100644
index 000000000..cb000310d
--- /dev/null
+++ b/user/plib/shared.patch
@@ -0,0 +1,288 @@
+diff -Naur plib-1.8.5.orig/configure.in plib-1.8.5/configure.in
+--- plib-1.8.5.orig/configure.in 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/configure.in 2008-04-17 13:47:10.000000000 +0100
+@@ -36,7 +36,7 @@
+ AC_PROG_CXX
+ AC_PROG_CXXCPP
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ dnl Command line arguments
+
+diff -Naur plib-1.8.5.orig/src/fnt/Makefile.am plib-1.8.5/src/fnt/Makefile.am
+--- plib-1.8.5.orig/src/fnt/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/fnt/Makefile.am 2008-04-17 13:52:53.000000000 +0100
+@@ -1,10 +1,12 @@
+ if BUILD_FNT
+
+-lib_LIBRARIES = libplibfnt.a
++lib_LTLIBRARIES = libplibfnt.la
+
+ include_HEADERS = fnt.h
+
+-libplibfnt_a_SOURCES = fnt.cxx fntTXF.cxx fntLocal.h fntBitmap.cxx
++libplibfnt_la_SOURCES = fnt.cxx fntTXF.cxx fntLocal.h fntBitmap.cxx
++libplibfnt_la_LIBADD = ../util/libplibul.la
++libplibfnt_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/js/Makefile.am plib-1.8.5/src/js/Makefile.am
+--- plib-1.8.5.orig/src/js/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/js/Makefile.am 2008-04-17 13:53:33.000000000 +0100
+@@ -1,12 +1,15 @@
+ if BUILD_JS
+
+-lib_LIBRARIES = libplibjs.a
++lib_LTLIBRARIES = libplibjs.la
+
+ include_HEADERS = js.h
+
+-libplibjs_a_SOURCES = js.cxx jsLinux.cxx jsLinuxOld.cxx jsMacOS.cxx \
++libplibjs_la_SOURCES = js.cxx jsLinux.cxx jsLinuxOld.cxx jsMacOS.cxx \
+ jsMacOSX.cxx jsWindows.cxx jsBSD.cxx \
+ jsNone.cxx
++libplibjs_la_LIBADD = ../util/libplibul.la
++libplibjs_la_LDFLAGS = -version-info 9:5:8
++
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/Makefile.am plib-1.8.5/src/Makefile.am
+--- plib-1.8.5.orig/src/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/Makefile.am 2008-04-17 14:16:21.000000000 +0100
+@@ -1 +1 @@
+-SUBDIRS = util js sl pui puAux sg ssg fnt ssgAux net psl pw
++SUBDIRS = util fnt sg js sl pui puAux ssg ssgAux net psl pw
+diff -Naur plib-1.8.5.orig/src/net/Makefile.am plib-1.8.5/src/net/Makefile.am
+--- plib-1.8.5.orig/src/net/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/net/Makefile.am 2008-04-17 13:54:12.000000000 +0100
+@@ -1,12 +1,14 @@
+ if BUILD_NET
+
+-lib_LIBRARIES = libplibnet.a
++lib_LTLIBRARIES = libplibnet.la
+
+ include_HEADERS = netBuffer.h netChannel.h netChat.h netMessage.h \
+ netMonitor.h netSocket.h net.h
+
+-libplibnet_a_SOURCES = netBuffer.cxx netChannel.cxx netChat.cxx \
++libplibnet_la_SOURCES = netBuffer.cxx netChannel.cxx netChat.cxx \
+ netMessage.cxx netMonitor.cxx netSocket.cxx
++libplibnet_la_LIBADD = ../util/libplibul.la
++libplibnet_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/psl/Makefile.am plib-1.8.5/src/psl/Makefile.am
+--- plib-1.8.5.orig/src/psl/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/psl/Makefile.am 2008-04-17 14:13:43.000000000 +0100
+@@ -1,16 +1,18 @@
+
+ if BUILD_PSL
+
+-lib_LIBRARIES = libplibpsl.a
++lib_LTLIBRARIES = libplibpsl.la
+
+ include_HEADERS = psl.h
+
+-libplibpsl_a_SOURCES = psl.cxx pslCodeGen.cxx pslContext.cxx \
++libplibpsl_la_SOURCES = psl.cxx pslCodeGen.cxx pslContext.cxx \
+ pslCompiler.cxx pslSymbols.cxx pslToken.cxx \
+ pslExpression.cxx pslProgram.cxx pslDump.cxx \
+ pslError.cxx pslFileIO.cxx pslCompiler.h \
+ pslContext.h pslFileIO.h pslLocal.h \
+ pslOpcodes.h pslSymbol.h
++libplibpsl_la_LIBADD = ../util/libplibul.la
++libplibpsl_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/puAux/Makefile.am plib-1.8.5/src/puAux/Makefile.am
+--- plib-1.8.5.orig/src/puAux/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/puAux/Makefile.am 2008-04-17 14:08:34.000000000 +0100
+@@ -1,10 +1,10 @@
+ if BUILD_PUAUX
+
+-lib_LIBRARIES = libplibpuaux.a
++lib_LTLIBRARIES = libplibpuaux.la
+
+ include_HEADERS = puAux.h puAuxLocal.h
+
+-libplibpuaux_a_SOURCES = puAux.cxx \
++libplibpuaux_la_SOURCES = puAux.cxx \
+ puAuxBiSlider.cxx \
+ puAuxBiSliderWithEnds.cxx \
+ puAuxComboBox.cxx \
+@@ -19,6 +19,9 @@
+ puAuxTriSlider.cxx \
+ puAuxVerticalMenu.cxx \
+ puAuxChooser.cxx
++libplibpuaux_la_LIBADD = ../util/libplibul.la ../pui/libplibpu.la \
++ ../fnt/libplibfnt.la ../sg/libplibsg.la
++libplibpuaux_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg \
+ -I$(top_srcdir)/src/pui \
+diff -Naur plib-1.8.5.orig/src/pui/Makefile.am plib-1.8.5/src/pui/Makefile.am
+--- plib-1.8.5.orig/src/pui/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/pui/Makefile.am 2008-04-17 14:09:12.000000000 +0100
+@@ -1,10 +1,10 @@
+ if BUILD_PUI
+
+-lib_LIBRARIES = libplibpu.a
++lib_LTLIBRARIES = libplibpu.la
+
+ include_HEADERS = pu.h puGLUT.h puFLTK.h puSDL.h puNative.h puPW.h
+
+-libplibpu_a_SOURCES = \
++libplibpu_la_SOURCES = \
+ pu.cxx puBox.cxx puButton.cxx puButtonBox.cxx \
+ puArrowButton.cxx puDialogBox.cxx puFrame.cxx puGroup.cxx \
+ puInput.cxx puInterface.cxx puLocal.h puMenuBar.cxx \
+@@ -14,6 +14,8 @@
+ puDial.cxx \
+ puRange.cxx \
+ puInputBase.cxx
++libplibpu_la_LIBADD = ../util/libplibul.la ../fnt/libplibfnt.la
++libplibpu_la_LDFLAGS = -version-info 9:5:8
+
+ AM_CPPFLAGS = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/fnt
+ AM_CPPFLAGS += -I$(top_srcdir)/src/util
+diff -Naur plib-1.8.5.orig/src/pw/Makefile.am plib-1.8.5/src/pw/Makefile.am
+--- plib-1.8.5.orig/src/pw/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/pw/Makefile.am 2008-04-17 14:13:46.000000000 +0100
+@@ -1,10 +1,11 @@
+ if BUILD_PW
+
+-lib_LIBRARIES = libplibpw.a
++lib_LTLIBRARIES = libplibpw.la
+
+ include_HEADERS = pw.h
+
+-libplibpw_a_SOURCES = pw.cxx pwX11.cxx pwWindows.cxx pwMacOSX.cxx
++libplibpw_la_SOURCES = pw.cxx pwX11.cxx pwWindows.cxx pwMacOSX.cxx
++libplibpw_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/sg/Makefile.am plib-1.8.5/src/sg/Makefile.am
+--- plib-1.8.5.orig/src/sg/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/sg/Makefile.am 2008-04-17 14:14:23.000000000 +0100
+@@ -1,12 +1,14 @@
+ if BUILD_SG
+
+-lib_LIBRARIES = libplibsg.a
++lib_LTLIBRARIES = libplibsg.la
+
+ include_HEADERS = sg.h
+
+-libplibsg_a_SOURCES = sg.cxx sgd.cxx \
++libplibsg_la_SOURCES = sg.cxx sgd.cxx \
+ sgIsect.cxx sgdIsect.cxx \
+ sgPerlinNoise.cxx
++libplibsg_la_LIBADD = ../util/libplibul.la
++libplibsg_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/sl/Makefile.am plib-1.8.5/src/sl/Makefile.am
+--- plib-1.8.5.orig/src/sl/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/sl/Makefile.am 2008-04-17 14:12:02.000000000 +0100
+@@ -1,16 +1,19 @@
+ if BUILD_SL
+
+-lib_LIBRARIES = libplibsl.a libplibsm.a
++lib_LTLIBRARIES = libplibsl.la libplibsm.la
+
+ include_HEADERS = sl.h slPortability.h sm.h
+
+-libplibsl_a_SOURCES = \
++libplibsl_la_SOURCES = \
+ slDSP.cxx slSample.cxx slEnvelope.cxx \
+ slPlayer.cxx slMODPlayer.cxx slSamplePlayer.cxx \
+ slScheduler.cxx slMODdacio.cxx slMODfile.cxx \
+ slMODinst.cxx slMODnote.cxx slMODPrivate.h slMODfile.h
++libplibsl_la_LIBADD = ../util/libplibul.la
++libplibsl_la_LDFLAGS = -version-info 9:5:8
+
+-libplibsm_a_SOURCES = slPortability.h smMixer.cxx
++libplibsm_la_SOURCES = slPortability.h smMixer.cxx
++libplibsm_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/ssg/Makefile.am plib-1.8.5/src/ssg/Makefile.am
+--- plib-1.8.5.orig/src/ssg/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/ssg/Makefile.am 2008-04-17 14:15:18.000000000 +0100
+@@ -1,10 +1,10 @@
+ if BUILD_SSG
+
+-lib_LIBRARIES = libplibssg.a
++lib_LTLIBRARIES = libplibssg.la
+
+ include_HEADERS = ssg.h ssgconf.h ssgMSFSPalette.h ssgKeyFlier.h pcx.h
+
+-libplibssg_a_SOURCES = ssg.cxx ssgAnimation.cxx ssgBase.cxx \
++libplibssg_la_SOURCES = ssg.cxx ssgAnimation.cxx ssgBase.cxx \
+ ssgBaseTransform.cxx ssgBranch.cxx ssgContext.cxx ssgCutout.cxx \
+ ssgDList.cxx ssgEntity.cxx ssgIsect.cxx ssgLeaf.cxx ssgList.cxx \
+ ssgLoadDOF.cxx ssgLoadAC.cxx \
+@@ -28,6 +28,8 @@
+ ssgLoadMDL_BGLTexture.cxx ssgLoadXPlaneObj.cxx ssgLoadASC.cxx ssgSaveASC.cxx \
+ ssgSaveIV.cxx ssgAnimTransform.cxx\
+ ssgVertSplitter.h ssgVertSplitter.cxx ssgStatistics.cxx
++libplibssg_la_LIBADD = ../util/libplibul.la ../sg/libplibsg.la
++libplibssg_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/util
+
+diff -Naur plib-1.8.5.orig/src/ssgAux/Makefile.am plib-1.8.5/src/ssgAux/Makefile.am
+--- plib-1.8.5.orig/src/ssgAux/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/ssgAux/Makefile.am 2008-04-17 14:14:50.000000000 +0100
+@@ -1,6 +1,6 @@
+ if BUILD_SSGAUX
+
+-lib_LIBRARIES = libplibssgaux.a
++lib_LTLIBRARIES = libplibssgaux.la
+
+ include_HEADERS = ssgAux.h \
+ ssgaShapes.h \
+@@ -13,7 +13,7 @@
+ ssgaFire.h \
+ ssgaBillboards.h
+
+-libplibssgaux_a_SOURCES = ssgAux.cxx \
++libplibssgaux_la_SOURCES = ssgAux.cxx \
+ ssgaShapes.cxx \
+ ssgaPatch.cxx \
+ ssgaParticleSystem.cxx \
+@@ -30,6 +30,9 @@
+ ssgaSky.cxx \
+ ssgaTeapot.cxx \
+ ssgaBillboards.cxx
++libplibssgaux_la_LIBADD = ../util/libplibul.la ../ssg/libplibssg.la \
++ ../sg/libplibsg.la
++libplibssgaux_la_LDFLAGS = -version-info 9:5:8
+
+ INCLUDES = -I$(top_srcdir)/src/sg -I$(top_srcdir)/src/ssg
+ INCLUDES += -I$(top_srcdir)/src/util
+diff -Naur plib-1.8.5.orig/src/util/Makefile.am plib-1.8.5/src/util/Makefile.am
+--- plib-1.8.5.orig/src/util/Makefile.am 2008-04-17 13:46:45.000000000 +0100
++++ plib-1.8.5/src/util/Makefile.am 2008-04-17 14:13:41.000000000 +0100
+@@ -1,11 +1,12 @@
+ if BUILD_UL
+
+-lib_LIBRARIES = libplibul.a
++lib_LTLIBRARIES = libplibul.la
+
+ include_HEADERS = ul.h ulRTTI.h
+
+-libplibul_a_SOURCES = ul.cxx ulClock.cxx ulError.cxx ulLinkedList.cxx \
++libplibul_la_SOURCES = ul.cxx ulClock.cxx ulError.cxx ulLinkedList.cxx \
+ ulList.cxx ulLocal.h ulRTTI.cxx
++libplibul_la_LDFLAGS = -version-info 9:5:8
+
+ endif
+