summaryrefslogtreecommitdiff
path: root/user/polkit
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-08-23 21:40:03 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-08-23 21:40:03 +0000
commitcc29c9098589ed06d7bb30419590142ab15d7dff (patch)
tree7540a4a443c52989dfdc461234bd1aefa5740cae /user/polkit
parent2ad01b22f76d7536b1b0b954e431d31e1de77d84 (diff)
downloadpackages-cc29c9098589ed06d7bb30419590142ab15d7dff.tar.gz
packages-cc29c9098589ed06d7bb30419590142ab15d7dff.tar.bz2
packages-cc29c9098589ed06d7bb30419590142ab15d7dff.tar.xz
packages-cc29c9098589ed06d7bb30419590142ab15d7dff.zip
user/polkit: Use elogind correctly
Diffstat (limited to 'user/polkit')
-rw-r--r--user/polkit/APKBUILD6
-rw-r--r--user/polkit/polkit-0.115-elogind.patch28
2 files changed, 32 insertions, 2 deletions
diff --git a/user/polkit/APKBUILD b/user/polkit/APKBUILD
index b55cb5d3b..c6d0cac92 100644
--- a/user/polkit/APKBUILD
+++ b/user/polkit/APKBUILD
@@ -19,6 +19,7 @@ source="https://www.freedesktop.org/software/polkit/releases/polkit-$pkgver.tar.
0001-make-netgroup-support-optional.patch
fix-consolekit-db-stat.patch
fix-test-fgetpwent.patch
+ polkit-0.115-elogind.patch
"
# secfixes:
@@ -47,7 +48,7 @@ build() {
--with-pam-include=base-auth \
--disable-gtk-doc-html \
--disable-gtk-doc-pdf \
- --disable-libsystemd-login
+ --enable-libelogind=yes
make
}
@@ -63,4 +64,5 @@ package() {
sha512sums="b66b01cc2bb4349de70147f41f161f0f6f41e7230b581dfb054058b48969ec57041ab05b51787c749ccfc36aa5f317952d7e7ba337b4f6f6c0a923ed5866c2d5 polkit-0.116.tar.gz
f13a350a040a80b705d28e2ce3fac183409f593dc360879ce1bc9ec85faa7796cf0f4e054098b737fb816369de6c9d598449f6908316484aac99a44a68102ae6 0001-make-netgroup-support-optional.patch
95493ef842b46ce9e724933a5d86083589075fb452435057b8f629643cac7c7eff67a24fd188087987e98057f0130757fad546d0c090767da3d71ebaf8485a24 fix-consolekit-db-stat.patch
-966825aded565432f4fda9e54113a773b514ebf7ee7faa83bcb8b97d218ae84a8707d6747bbc3cb8a828638d692fdef34c05038f150ad38e02a29f2c782aba5b fix-test-fgetpwent.patch"
+966825aded565432f4fda9e54113a773b514ebf7ee7faa83bcb8b97d218ae84a8707d6747bbc3cb8a828638d692fdef34c05038f150ad38e02a29f2c782aba5b fix-test-fgetpwent.patch
+06432fa56788699762c6978484640554f91728a1cb40679eb47b8514b3c7aa23aac5b9c26586eb4d7043a0af1b319bbe7f869d24844d9151317299b74a8e8f7f polkit-0.115-elogind.patch"
diff --git a/user/polkit/polkit-0.115-elogind.patch b/user/polkit/polkit-0.115-elogind.patch
new file mode 100644
index 000000000..93d672015
--- /dev/null
+++ b/user/polkit/polkit-0.115-elogind.patch
@@ -0,0 +1,28 @@
+From 08bb656496cd3d6213bbe9473f63f2d4a110da6e Mon Sep 17 00:00:00 2001
+From: Rasmus Thomsen <cogitri@exherbo.org>
+Date: Wed, 11 Apr 2018 13:14:14 +0200
+Subject: [PATCH] configure: fix elogind support
+
+HAVE_LIBSYSTEMD is used to determine which source files to use.
+We have to check if either have_libsystemd or have_libelogind is
+true, as both of these need the source files which are used when
+HAVE_LIBSYSTEMD is true.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 36df239..da47ecb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -221,7 +221,7 @@ AS_IF([test "x$cross_compiling" != "xyes" ], [
+
+ AC_SUBST(LIBSYSTEMD_CFLAGS)
+ AC_SUBST(LIBSYSTEMD_LIBS)
+-AM_CONDITIONAL(HAVE_LIBSYSTEMD, [test "$have_libsystemd" = "yes"], [Using libsystemd])
++AM_CONDITIONAL(HAVE_LIBSYSTEMD, [test "$have_libsystemd" = "yes" || test "$have_libelogind" = "yes" ], [Using libsystemd])
+
+ dnl ---------------------------------------------------------------------------
+ dnl - systemd unit / service files
+--
+2.17.0