summaryrefslogtreecommitdiff
path: root/user/polkit
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 07:29:00 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 07:29:00 -0600
commitd00b149bc5c53bc3215e94c57a6ea5257ec37647 (patch)
tree98e3a8c25f26cb27ff4394e6f8598324af615f59 /user/polkit
parent52bf3b0d577c4c42fa1d3839ed1b3a9ac95145ca (diff)
downloadpackages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.tar.gz
packages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.tar.bz2
packages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.tar.xz
packages-d00b149bc5c53bc3215e94c57a6ea5257ec37647.zip
user/[libraries]: modernise and fix syntax
Diffstat (limited to 'user/polkit')
-rw-r--r--user/polkit/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/user/polkit/APKBUILD b/user/polkit/APKBUILD
index 54ecc7f98..26d66a893 100644
--- a/user/polkit/APKBUILD
+++ b/user/polkit/APKBUILD
@@ -10,11 +10,11 @@ options="!check suid" # Requires running ConsoleKit and PolKit for JS backend
license="LGPL-2.0+"
depends=""
makedepends="glib-dev gobject-introspection-dev gtk-doc intltool linux-pam-dev
- mozjs-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+ mozjs-dev autoconf automake libtool"
pkgusers="polkitd"
pkggroups="polkitd"
install="$pkgname.pre-install $pkgname.pre-upgrade"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://www.freedesktop.org/software/polkit/releases/polkit-$pkgver.tar.gz
0001-make-netgroup-support-optional.patch
fix-consolekit-db-stat.patch
@@ -26,13 +26,11 @@ source="https://www.freedesktop.org/software/polkit/releases/polkit-$pkgver.tar.
# - CVE-2018-19788
prepare() {
- cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -56,12 +54,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}