summaryrefslogtreecommitdiff
path: root/user/ponysay
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-13 21:35:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-13 21:35:19 -0500
commit801055e5d98ad397517fa41e6980466678d0cbef (patch)
tree4db00193969e3a04e826f8192610eda298629e7d /user/ponysay
parent4801e84a85ced7b697d5f33f7bcc40dda2a0423d (diff)
downloadpackages-801055e5d98ad397517fa41e6980466678d0cbef.tar.gz
packages-801055e5d98ad397517fa41e6980466678d0cbef.tar.bz2
packages-801055e5d98ad397517fa41e6980466678d0cbef.tar.xz
packages-801055e5d98ad397517fa41e6980466678d0cbef.zip
maybe if I'm really quiet, nobody will notice, since Emily's offline...
Diffstat (limited to 'user/ponysay')
-rw-r--r--user/ponysay/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/user/ponysay/APKBUILD b/user/ponysay/APKBUILD
new file mode 100644
index 000000000..9e2001359
--- /dev/null
+++ b/user/ponysay/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=ponysay
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Like cowsay, but with horses"
+url="https://github.com/erkin/ponysay"
+arch="noarch"
+license="GPL-3.0 CC-BY-NC OTHER"
+depends="python3"
+makedepends="gzip texinfo"
+install=""
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch"
+source="ponysay-$pkgver.tar.gz::https://github.com/erkin/ponysay/archive/$pkgver.tar.gz"
+builddir="$srcdir/ponysay-$pkgver"
+
+build() {
+ cd "$builddir"
+}
+
+check() {
+ cd "$builddir"
+ ./dependency-test.sh
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --destdir="$pkgdir" --with-man \
+ --freedom=sloppy --without-fish
+}
+
+bashcomp() {
+ pkgdesc="Bash completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+}
+
+zshcomp() {
+ pkgdesc="Z Shell completions for $pkgname"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/zsh "$subpkgdir"/usr/share/
+}
+
+sha512sums="d6ff905404192bdc207952a4a914458d7f25ddcfcea95763ae277a2a3bc7ab33e86a0a229c1b10ff7295b7a89d6e1b61406feefb6bdf9026f4076d0ed70dbe93 ponysay-3.0.3.tar.gz"