summaryrefslogtreecommitdiff
path: root/user/py3-certifi
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2018-11-21 03:16:56 -0800
committerzlg <zlg@zlg.space>2018-11-21 03:35:28 -0800
commit3fc0772bb8787e8343b2cfa9b4f15693f948bf8c (patch)
tree3e930356f7981584416c3bb9dd4a0625e6181245 /user/py3-certifi
parent4bf0cc4d31e4a67a061e726ed6d54cbfcbc23e8d (diff)
downloadpackages-3fc0772bb8787e8343b2cfa9b4f15693f948bf8c.tar.gz
packages-3fc0772bb8787e8343b2cfa9b4f15693f948bf8c.tar.bz2
packages-3fc0772bb8787e8343b2cfa9b4f15693f948bf8c.tar.xz
packages-3fc0772bb8787e8343b2cfa9b4f15693f948bf8c.zip
user/py3-certifi: new package
Diffstat (limited to 'user/py3-certifi')
-rw-r--r--user/py3-certifi/APKBUILD30
-rw-r--r--user/py3-certifi/use-system-certs.patch13
2 files changed, 43 insertions, 0 deletions
diff --git a/user/py3-certifi/APKBUILD b/user/py3-certifi/APKBUILD
new file mode 100644
index 000000000..a7dd40dd9
--- /dev/null
+++ b/user/py3-certifi/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-certifi
+_pkgname=${pkgname#py3-}
+pkgver=2018.8.24
+pkgrel=0
+pkgdesc="Python package for providing Mozilla's CA Bundle"
+url="https://pypi.python.org/pypi/certifi"
+arch="noarch"
+options="!check" # no tests
+license="MPL-2.0"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ use-system-certs.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bb0af24570dd4806bc80cd438cae42db82f820de815a6148b184f58c19cd91a03f9275815559817a84220dcbd7c87a4a7d12e35cf4a95a1dbad286a1dfecf907 certifi-2018.8.24.tar.gz
+1de38c55102b41bc91870b4810de89d8b0cffd61ba14257fe6c8445173b8b44153f2736050772eb63dd0a755890afe0f2d27516bbd39f05bf4016a4e29eebb67 use-system-certs.patch"
diff --git a/user/py3-certifi/use-system-certs.patch b/user/py3-certifi/use-system-certs.patch
new file mode 100644
index 000000000..bf315aa2f
--- /dev/null
+++ b/user/py3-certifi/use-system-certs.patch
@@ -0,0 +1,13 @@
+--- a/certifi/core.py 2018-01-18 12:27:24.000000000 -0800
++++ b/certifi/core.py 2018-11-20 18:08:48.230610538 -0800
+@@ -19,9 +19,7 @@
+
+
+ def where():
+- f = os.path.dirname(__file__)
+-
+- return os.path.join(f, 'cacert.pem')
++ return "/etc/ssl/certs/ca-certificates.crt"
+
+
+ def old_where():