summaryrefslogtreecommitdiff
path: root/user/py3-cffi
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 20:15:41 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 20:15:41 +0000
commit7057cc06aae39037d7f0b84b51d7689ffbfe2249 (patch)
treea5150d785e0f9df7825c37958764a7b3986f7d00 /user/py3-cffi
parentfdcd2d12da90ef34f8afb092f1e7b3bd07eb6ec5 (diff)
downloadpackages-7057cc06aae39037d7f0b84b51d7689ffbfe2249.tar.gz
packages-7057cc06aae39037d7f0b84b51d7689ffbfe2249.tar.bz2
packages-7057cc06aae39037d7f0b84b51d7689ffbfe2249.tar.xz
packages-7057cc06aae39037d7f0b84b51d7689ffbfe2249.zip
user/py3-cffi: new package
Diffstat (limited to 'user/py3-cffi')
-rw-r--r--user/py3-cffi/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-cffi/APKBUILD b/user/py3-cffi/APKBUILD
new file mode 100644
index 000000000..22a0301bd
--- /dev/null
+++ b/user/py3-cffi/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-cffi
+pkgver=1.11.5
+pkgrel=0
+pkgdesc="Interface for Python to call in to C code"
+url="https://cffi.readthedocs.io/"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-pytest"
+subpackages=""
+source="https://files.pythonhosted.org/packages/e7/a7/4cd50e57cc6f436f1cc3a7e8fa700ff9b8b4d471620629074913e3735fb2/cffi-$pkgver.tar.gz"
+builddir="$srcdir/cffi-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6770d5293cfd7405e733d60c96655641b5bcc5878fc66a737f4a8308f465d459ee0e3fcaa47893d8f57fb195e5534dd7e4728c868f33d7e657688f45e1fb1880 cffi-1.11.5.tar.gz"