summaryrefslogtreecommitdiff
path: root/user/py3-html5lib/APKBUILD
diff options
context:
space:
mode:
authorBrandon Bergren <git@bdragon.rtk0.net>2019-04-06 21:58:09 -0500
committerBrandon Bergren <git@bdragon.rtk0.net>2019-04-06 21:59:00 -0500
commit64d7aa8301c599bf348897882e50f2a94d7b60df (patch)
tree8799e43393728de837605821b7133e99086b9a81 /user/py3-html5lib/APKBUILD
parentf900125406ef285e9234a64575800b6b315c7578 (diff)
downloadpackages-64d7aa8301c599bf348897882e50f2a94d7b60df.tar.gz
packages-64d7aa8301c599bf348897882e50f2a94d7b60df.tar.bz2
packages-64d7aa8301c599bf348897882e50f2a94d7b60df.tar.xz
packages-64d7aa8301c599bf348897882e50f2a94d7b60df.zip
Add py3-sphinx and its dependencies.
This will be needed in the future to build qemu-doc for qemu 4.0.
Diffstat (limited to 'user/py3-html5lib/APKBUILD')
-rw-r--r--user/py3-html5lib/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-html5lib/APKBUILD b/user/py3-html5lib/APKBUILD
new file mode 100644
index 000000000..f65096fad
--- /dev/null
+++ b/user/py3-html5lib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Brandon Bergren <git@bdragon.rtk0.net>
+# Maintainer: Brandon Bergren <git@bdragon.rtk0.net>
+pkgname=py3-html5lib
+_pkgname=html5lib
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="HTML parser based on the WHATWG HTML specification"
+url="https://pypi.python.org/pypi/html5lib"
+arch="noarch"
+license="MIT"
+depends="python3 py3-six py3-webencodings"
+makedepends="python3-dev"
+checkdepends="py3-pytest py3-mock py3-pytest-expect"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ pytest
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 py3-html5lib-1.0.1.tar.gz"