summaryrefslogtreecommitdiff
path: root/user/py3-olefile
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-04-18 17:50:20 -0400
committerMax Rees <maxcrees@me.com>2018-04-18 17:56:57 -0400
commit039e6f7bfe16fb2c149a9c60436e033a57074247 (patch)
tree902d3ac6e55fb677b5be54adbd7741001cdd0beb /user/py3-olefile
parent752c72a485371af594aa449521439c70e60ecf75 (diff)
downloadpackages-039e6f7bfe16fb2c149a9c60436e033a57074247.tar.gz
packages-039e6f7bfe16fb2c149a9c60436e033a57074247.tar.bz2
packages-039e6f7bfe16fb2c149a9c60436e033a57074247.tar.xz
packages-039e6f7bfe16fb2c149a9c60436e033a57074247.zip
user/py3-olefile: upgrade to 0.45.1
Mostly small changes, but important to note is that the legacy OleFileIO_PL module has been dropped. Commits: https://github.com/decalage2/olefile/compare/v0.44...v0.45.1
Diffstat (limited to 'user/py3-olefile')
-rw-r--r--user/py3-olefile/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/user/py3-olefile/APKBUILD b/user/py3-olefile/APKBUILD
index 4709626ae..06bbd6951 100644
--- a/user/py3-olefile/APKBUILD
+++ b/user/py3-olefile/APKBUILD
@@ -2,20 +2,17 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-olefile
_pkgname=olefile
-pkgver=0.44
+pkgver=0.45.1
pkgrel=0
pkgdesc="A Python module to read/write MS OLE2 files"
-url="https://pypi.python.org/pypi/olefile"
+url="https://pypi.python.org/project/olefile"
arch="noarch"
-license="Custom"
+license="BSD-2-Clause Custom"
depends="python3"
-makedepends="py3-setuptools python3-dev"
+makedepends="py3-setuptools python3-dev unzip"
install=""
giturl="https://github.com/decalage2/olefile"
-verbase="$pkgver"
-reporev="v$pkgver"
-# The downloads from GitHub are missing the test files
-source="https://dev.sick.bike/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/o/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -31,6 +28,7 @@ check() {
package() {
cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
-sha512sums="bece8b040cb3572c1fa2536a21c1de4c05e560b641e1c6e4bf66772135c43d29e06c7fc47d6c07d3c351b1f741f49c63201657634c33e9124de892e9a0cc053f py3-olefile-0.44.tar.gz"
+sha512sums="31f7584553304b186aad88f1988dfa12ceb34a50d546a38181280a816cfcda8dc54ff502afb31a928d647e6106c9e4878bfac8cec31d24018fdbab65c7007e49 py3-olefile-0.45.1.zip"