summaryrefslogtreecommitdiff
path: root/user/py3-packaging
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 08:13:03 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 08:18:23 -0500
commit72bedd94956da15e9ddee28d50e071253922c0da (patch)
treea27ad6c02696e251aae60100df3383d31be8ea45 /user/py3-packaging
parent14c406339da6f5ff970b71c38f84218de51b423c (diff)
downloadpackages-72bedd94956da15e9ddee28d50e071253922c0da.tar.gz
packages-72bedd94956da15e9ddee28d50e071253922c0da.tar.bz2
packages-72bedd94956da15e9ddee28d50e071253922c0da.tar.xz
packages-72bedd94956da15e9ddee28d50e071253922c0da.zip
user/py3-packaging: fix dependencies, bump to 19.1
Depends on py3-attrs, py3-six, and py3-pyparsing which wasn't correctly specified before.
Diffstat (limited to 'user/py3-packaging')
-rw-r--r--user/py3-packaging/APKBUILD18
-rw-r--r--user/py3-packaging/test-glibc.patch10
2 files changed, 19 insertions, 9 deletions
diff --git a/user/py3-packaging/APKBUILD b/user/py3-packaging/APKBUILD
index 87527b822..678fc4872 100644
--- a/user/py3-packaging/APKBUILD
+++ b/user/py3-packaging/APKBUILD
@@ -4,32 +4,32 @@ pkgname=py3-packaging
_pkgname=packaging
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
-pkgver=19.0
+pkgver=19.1
pkgrel=0
pkgdesc="Core utilities for Python packages"
url="https://pypi.python.org/pypi/packaging"
arch="noarch"
+# Certified net clean
license="Apache-2.0 AND BSD-2-Clause"
-depends="python3"
+depends="python3 py3-attrs py3-pyparsing py3-six"
makedepends="python3-dev"
-checkdepends="py3-pytest py3-pretend py3-pyparsing"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-pytest py3-pretend"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ test-glibc.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir/tests"
- python3 -m pytest
+ PYTHONPATH="$builddir" pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="aa55b6fbca764e7de2992e294b7be9dc90b25f88b64ba0cd2d1d93042402d4360b4c2cdc134a94b083da0c0bc83de8fa7185c0856bcc96fa25828c10a793fba7 py3-packaging-19.0.tar.gz"
+sha512sums="1dec7f49c325801eb85b11432f8a316d228bb1881a04ac546f5556d60f5fa33f8085d0e91bbd5abfeb30bfcb05ec0532ed75a977dc996e256b4dc8c27c10e79b py3-packaging-19.1.tar.gz
+d67e8f3eae1b7571edf705ba532e1c9a6dc4c241cb01dfeda8addb587c2039114b0e21e73140369e4a30d0256a2073ac877737458cb95006029e7ce44d0bae93 test-glibc.patch"
diff --git a/user/py3-packaging/test-glibc.patch b/user/py3-packaging/test-glibc.patch
new file mode 100644
index 000000000..b8c3f2fee
--- /dev/null
+++ b/user/py3-packaging/test-glibc.patch
@@ -0,0 +1,10 @@
+--- packaging-19.1/tests/test_tags.py 2019-07-20 01:03:21.000000000 -0400
++++ packaging-19.1/tests/test_tags.py 2019-08-06 09:08:16.490018542 -0400
+@@ -474,6 +474,7 @@ def test_glibc_version_string(version_st
+ assert tags._glibc_version_string() is None
+
+
++@pytest.mark.skip(reason="musl is not glibc")
+ def test_have_compatible_glibc(monkeypatch):
+ if platform.system() == "Linux":
+ # Assuming no one is running this test with a version of glibc released in