summaryrefslogtreecommitdiff
path: root/user/py3-paho-mqtt/setup.patch
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-27 21:59:22 -0500
committerMax Rees <maxcrees@me.com>2019-08-27 21:59:22 -0500
commit487bfc735971d4f3f42397173f40dd743a8044f0 (patch)
tree72c0d855f59f21c8cbf606c00878a92a5f6dde99 /user/py3-paho-mqtt/setup.patch
parenta1ee5f0e6ac73ea9cc57706114ed0b43d6c691fe (diff)
downloadpackages-487bfc735971d4f3f42397173f40dd743a8044f0.tar.gz
packages-487bfc735971d4f3f42397173f40dd743a8044f0.tar.bz2
packages-487bfc735971d4f3f42397173f40dd743a8044f0.tar.xz
packages-487bfc735971d4f3f42397173f40dd743a8044f0.zip
user/py3-paho-mqtt: new package
Diffstat (limited to 'user/py3-paho-mqtt/setup.patch')
-rw-r--r--user/py3-paho-mqtt/setup.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/py3-paho-mqtt/setup.patch b/user/py3-paho-mqtt/setup.patch
new file mode 100644
index 000000000..70ccc869f
--- /dev/null
+++ b/user/py3-paho-mqtt/setup.patch
@@ -0,0 +1,24 @@
+--- paho.mqtt.python-1.4.0/setup.py 2018-09-02 11:20:42.000000000 +0000
++++ paho.mqtt.python-1.4.0/setup.py 2019-08-28 02:51:55.690633661 +0000
+@@ -11,9 +11,8 @@ with open('README.rst', 'rb') as readme_
+ readme = readme_file.read().decode('utf-8')
+
+ requirements = []
+-test_requirements = ['pytest', 'pylama']
+-needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
+-setup_requirements = ['pytest-runner'] if needs_pytest else []
++test_requirements = ['pytest']
++setup_requirements = []
+
+ if sys.version_info < (3, 0):
+ test_requirements += ['mock']
+--- paho.mqtt.python-1.4.0/setup.cfg 2018-09-02 11:20:42.000000000 +0000
++++ paho.mqtt.python-1.4.0/setup.cfg 2019-08-28 02:50:19.540632984 +0000
+@@ -1,7 +1,6 @@
+ [aliases]
+ test=pytest
+ [tool:pytest]
+-addopts=-r xs --pylama
+ strict=True
+ testpaths=tests src
+ [pylama]