summaryrefslogtreecommitdiff
path: root/user/py3-pluggy
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-01-10 17:52:35 +0000
committerMax Rees <maxcrees@me.com>2018-01-11 04:36:54 +0000
commitc48350952818d179f3f4883d8574eb8fd43bbb28 (patch)
tree3a026aca6b96166455d4118a84a9f518f48349be /user/py3-pluggy
parentcee386a7d341f6ad530f58bd7ec2785b935cda79 (diff)
downloadpackages-c48350952818d179f3f4883d8574eb8fd43bbb28.tar.gz
packages-c48350952818d179f3f4883d8574eb8fd43bbb28.tar.bz2
packages-c48350952818d179f3f4883d8574eb8fd43bbb28.tar.xz
packages-c48350952818d179f3f4883d8574eb8fd43bbb28.zip
user/py3-pluggy: new package
Diffstat (limited to 'user/py3-pluggy')
-rw-r--r--user/py3-pluggy/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-pluggy/APKBUILD b/user/py3-pluggy/APKBUILD
new file mode 100644
index 000000000..b71d8de07
--- /dev/null
+++ b/user/py3-pluggy/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pluggy
+_pkgname=pluggy
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Plugin management and hook calling for Python"
+url="https://pypi.python.org/pypi/pluggy"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-tox"
+options="!check" # Cyclic dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36-pytestrelease
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812 py3-pluggy-0.6.0.tar.gz"