summaryrefslogtreecommitdiff
path: root/user/py3-py
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-10-11 01:50:08 -0400
committerMax Rees <maxcrees@me.com>2018-10-22 20:22:08 -0400
commitf89370f674e3ec1bc46261a867a6e01fe0b13846 (patch)
treeb2e1a04a93bb7b685cfcfc86135053841c0a944c /user/py3-py
parentc8eb5d4d462a8e3635e41c927af84dab33fa9eca (diff)
downloadpackages-f89370f674e3ec1bc46261a867a6e01fe0b13846.tar.gz
packages-f89370f674e3ec1bc46261a867a6e01fe0b13846.tar.bz2
packages-f89370f674e3ec1bc46261a867a6e01fe0b13846.tar.xz
packages-f89370f674e3ec1bc46261a867a6e01fe0b13846.zip
user/py3-py: bump to 1.7.0, drop py3-tox dep
Diffstat (limited to 'user/py3-py')
-rw-r--r--user/py3-py/APKBUILD17
-rw-r--r--user/py3-py/scm.patch12
2 files changed, 21 insertions, 8 deletions
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index a17fe96d1..a38f90caf 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
-pkgver=1.5.3
+pkgver=1.7.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
arch="noarch"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
+options="!checkroot !check" # Circular dependency with py3-pytest. Passes on x86_64
+# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
-#checkdepends="py3-tox"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+#checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -21,10 +23,8 @@ build() {
}
check() {
- # Can't use py3-pytest > 3.0 as of py3-py==1.5.3-r0 because some tests
- # haven't been updated yet
cd "$builddir"
- tox -e py36-pytest30
+ PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
@@ -32,4 +32,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py3-py-1.5.3.tar.gz"
+sha512sums="c522be926c5716d866cb800eaa398a55518889da207a00575212254642eda2107e68c286e72b99cf94ecec1c8dcde1f763e2d8f296ab7e7673ae2671e70d5548 py3-py-1.7.0.tar.gz
+08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"
diff --git a/user/py3-py/scm.patch b/user/py3-py/scm.patch
new file mode 100644
index 000000000..44665748f
--- /dev/null
+++ b/user/py3-py/scm.patch
@@ -0,0 +1,12 @@
+--- py-1.7.0/setup.py 2018-08-27 20:39:51.000000000 +0000
++++ py-1.7.0/setup.py 2018-10-11 05:07:12.560247181 +0000
+@@ -6,8 +6,7 @@ def main():
+ name='py',
+ description='library with cross-python path, ini-parsing, io, code, log facilities',
+ long_description=open('README.rst').read(),
+- use_scm_version={"write_to": "py/_version.py"},
+- setup_requires=["setuptools-scm"],
++ version='1.7.0',
+ url='http://py.readthedocs.io/',
+ license='MIT license',
+ platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],