summaryrefslogtreecommitdiff
path: root/user/py3-pycairo
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-26 21:39:33 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-04-26 21:39:33 -0500
commit67ffcdf76ac98d9d6b989c6b77f594f0f24a0156 (patch)
tree050c96c503abcc949d27162a3a8e90f496e0f2b0 /user/py3-pycairo
parent5eb86763170935619bc664130ddfadf4b7c7677d (diff)
downloadpackages-67ffcdf76ac98d9d6b989c6b77f594f0f24a0156.tar.gz
packages-67ffcdf76ac98d9d6b989c6b77f594f0f24a0156.tar.bz2
packages-67ffcdf76ac98d9d6b989c6b77f594f0f24a0156.tar.xz
packages-67ffcdf76ac98d9d6b989c6b77f594f0f24a0156.zip
user/py3-pycairo: upgrade to 1.18.1
Diffstat (limited to 'user/py3-pycairo')
-rw-r--r--user/py3-pycairo/APKBUILD9
-rw-r--r--user/py3-pycairo/meson-idiocy.patch27
2 files changed, 3 insertions, 33 deletions
diff --git a/user/py3-pycairo/APKBUILD b/user/py3-pycairo/APKBUILD
index 9dce8a2ed..0b725ba6e 100644
--- a/user/py3-pycairo/APKBUILD
+++ b/user/py3-pycairo/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=py3-pycairo
-pkgver=1.18.0
+pkgver=1.18.1
pkgrel=0
pkgdesc="Python bindings for Cairo"
url="https://pycairo.readthedocs.io/"
@@ -10,9 +10,7 @@ license="MIT AND (LGPL-2.1-only OR MPL-1.1)"
depends=""
makedepends="python3-dev cairo-dev meson"
subpackages="$pkgname-dev"
-source="https://files.pythonhosted.org/packages/source/p/pycairo/pycairo-$pkgver.tar.gz
- meson-idiocy.patch
- "
+source="https://files.pythonhosted.org/packages/source/p/pycairo/pycairo-$pkgver.tar.gz"
builddir="$srcdir/pycairo-$pkgver"
build() {
@@ -36,5 +34,4 @@ package() {
DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="29af1eff8fc3ca942c6d7fcda8e5e004f01d1bfdab911f4ebb34213520922cf35c12d07bd18fe74a2c6d3c7f5a1aefd7fb5fe9b7cd310e6707b7451d5d5e18b0 pycairo-1.18.0.tar.gz
-33d400b1c27c549f0962d08e50ca4a6614e714896f5cca76128f8b4d3aac4c07b50bab03ee611de2e17d4c0001bbe3f4f02137e8988b040e9deea911607ad917 meson-idiocy.patch"
+sha512sums="fef6b0d863d45a182a1ba671ddc4f6cb15745447cdaed3e1efeb05fad97f02aa0a56698517648a942bde263d74e06ad7781bcf487757aeb3b124ef64dc525024 pycairo-1.18.1.tar.gz"
diff --git a/user/py3-pycairo/meson-idiocy.patch b/user/py3-pycairo/meson-idiocy.patch
deleted file mode 100644
index 99ed7d71c..000000000
--- a/user/py3-pycairo/meson-idiocy.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 878932bf9c1545d659822961459a2601287b1675 Mon Sep 17 00:00:00 2001
-From: Christoph Reiter <reiter.christoph@gmail.com>
-Date: Sat, 23 Mar 2019 22:26:01 +0100
-Subject: [PATCH] meson: fix configure error with meson 0.50 re absolute paths.
- Fixes #144
-
-The newest meson version has started to fail:
-meson.build:62:0: ERROR: Subdir keyword must not be an absolute path.
-
-Fix by using install_dir instead of subdir.
----
- cairo/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/cairo/meson.build b/cairo/meson.build
-index 6a1bde3..3e3b2cc 100644
---- a/cairo/meson.build
-+++ b/cairo/meson.build
-@@ -61,7 +61,7 @@ header_file = configure_file(
-
- install_headers(
- [header_file],
-- subdir: join_paths(python.get_install_dir(), 'cairo', 'include'),
-+ install_dir: join_paths(python.get_install_dir(), 'cairo', 'include'),
- )
- install_headers([header_file], subdir: 'pycairo')
-