summaryrefslogtreecommitdiff
path: root/user/py3-pycairo
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-06 21:38:57 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-06 21:38:57 +0000
commit8f8a0eb8788f35c1ca5db3730bcc10535934c05e (patch)
tree9fb43a334a0c10b0c9a7167fb056d56892684cf1 /user/py3-pycairo
parentad24c013617b1481d0830fafd0555f6a02cd199f (diff)
downloadpackages-8f8a0eb8788f35c1ca5db3730bcc10535934c05e.tar.gz
packages-8f8a0eb8788f35c1ca5db3730bcc10535934c05e.tar.bz2
packages-8f8a0eb8788f35c1ca5db3730bcc10535934c05e.tar.xz
packages-8f8a0eb8788f35c1ca5db3730bcc10535934c05e.zip
user/*: Modernise / fix syntax / deps etc
Diffstat (limited to 'user/py3-pycairo')
-rw-r--r--user/py3-pycairo/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/user/py3-pycairo/APKBUILD b/user/py3-pycairo/APKBUILD
index 3939f9af3..d5f3e01b3 100644
--- a/user/py3-pycairo/APKBUILD
+++ b/user/py3-pycairo/APKBUILD
@@ -6,15 +6,16 @@ pkgrel=0
pkgdesc="Python bindings for Cairo"
url="https://pycairo.readthedocs.io/"
arch="all"
+options="!check" # Test suite requires unpackaged py3-flake8.
license="MIT AND (LGPL-2.1-only OR MPL-1.1)"
depends=""
+checkdepends="py3-pytest"
makedepends="python3-dev cairo-dev meson"
subpackages="$pkgname-dev"
source="https://files.pythonhosted.org/packages/source/p/pycairo/pycairo-$pkgver.tar.gz"
builddir="$srcdir/pycairo-$pkgver"
build() {
- cd "$builddir"
meson \
--prefix=/usr \
--sysconfdir=/etc \
@@ -26,11 +27,10 @@ build() {
}
check() {
- cd "$builddir"
+ ninja -C output test
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install
}