summaryrefslogtreecommitdiff
path: root/user/py3-pytest/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-01-10 23:08:23 +0000
committerMax Rees <maxcrees@me.com>2018-01-11 04:33:21 +0000
commitb2047b2fa329a77e1260bb797936be0fff8c5b0b (patch)
tree0b4306c766823bdcc7eb4080de0aef36500b4b34 /user/py3-pytest/APKBUILD
parentcee386a7d341f6ad530f58bd7ec2785b935cda79 (diff)
downloadpackages-b2047b2fa329a77e1260bb797936be0fff8c5b0b.tar.gz
packages-b2047b2fa329a77e1260bb797936be0fff8c5b0b.tar.bz2
packages-b2047b2fa329a77e1260bb797936be0fff8c5b0b.tar.xz
packages-b2047b2fa329a77e1260bb797936be0fff8c5b0b.zip
user/py3-pytest: new package
Diffstat (limited to 'user/py3-pytest/APKBUILD')
-rw-r--r--user/py3-pytest/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/py3-pytest/APKBUILD b/user/py3-pytest/APKBUILD
new file mode 100644
index 000000000..39b723529
--- /dev/null
+++ b/user/py3-pytest/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pytest
+_pkgname=pytest
+pkgver=3.2.2
+pkgrel=0
+pkgdesc="A python test library"
+url="https://pypi.python.org/pypi/pytest"
+arch="noarch"
+license="MIT"
+depends="python3 py3-py"
+makedepends="py3-setuptools python3-dev"
+#checkdepends="py3-tox"
+options="!check" # Circular dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db py3-pytest-3.2.2.tar.gz"