summaryrefslogtreecommitdiff
path: root/user/py3-pytest
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 08:29:17 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 08:31:08 -0500
commit3350abe8925d99bc448b9c190c94ff13b84a7625 (patch)
tree63883e8b660445721ce14a14d16798b2fd917db3 /user/py3-pytest
parent72bedd94956da15e9ddee28d50e071253922c0da (diff)
downloadpackages-3350abe8925d99bc448b9c190c94ff13b84a7625.tar.gz
packages-3350abe8925d99bc448b9c190c94ff13b84a7625.tar.bz2
packages-3350abe8925d99bc448b9c190c94ff13b84a7625.tar.xz
packages-3350abe8925d99bc448b9c190c94ff13b84a7625.zip
user/py3-pytest: bump to 5.0.1
Diffstat (limited to 'user/py3-pytest')
-rw-r--r--user/py3-pytest/APKBUILD12
-rw-r--r--user/py3-pytest/scm.patch19
2 files changed, 14 insertions, 17 deletions
diff --git a/user/py3-pytest/APKBUILD b/user/py3-pytest/APKBUILD
index 6965bf73a..63616f400 100644
--- a/user/py3-pytest/APKBUILD
+++ b/user/py3-pytest/APKBUILD
@@ -2,16 +2,16 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pytest
_pkgname=pytest
-pkgver=3.9.1
+pkgver=5.0.1
pkgrel=0
pkgdesc="A python test library"
url="https://pypi.python.org/pypi/pytest"
arch="noarch"
-options="!checkroot !check" # Cyclic dependency with itself. Passes on x86_64
+options="!check" # Cyclic dependency with itself. Passes on x86_64
# Certified net clean
license="MIT"
depends="python3 py3-atomicwrites py3-attrs py3-more-itertools
- py3-pluggy py3-py py3-six"
+ py3-packaging py3-pluggy py3-py py3-six py3-wcwidth"
makedepends="python3-dev"
#checkdepends="py3-pytest py3-hypothesis"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
@@ -19,12 +19,10 @@ source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
# You would think you could get away with "python3 -m pytest" but no...
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
@@ -34,5 +32,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0a3a6842fb549c8223f0ddf56ca28eb200a21a4cadf382fbcd2ab930c58d57c55c77d5869e84bd79bf611d959cba6d363ace3b5fd33d5ce44259fd580b1a9369 py3-pytest-3.9.1.tar.gz
-7fc2cd75f55caa661fb4bed578955511ee38cd28a25fcb405c29eb7227a382c33c0fc52a4eeb8950315793dfc0eb02235b140415deebd113f24df1a320b25959 scm.patch"
+sha512sums="92f5feb263a8708ef6cb8f4565688620b6bfeaef23536cfd24b9bc09515e37fdecd7fa8bcaeeb0775c0be1d8e9dcbd9a56e52f97fb13dc98116efc0056f870db py3-pytest-5.0.1.tar.gz
+c671edd19cf5bfe1502e2c42a1b301205417c5d4f564a8dd02ddad354021b0a8b4d01cc0f5d7c36b13d56583c18cd6a1db736b7d49634c0fb2d1159b429dafda scm.patch"
diff --git a/user/py3-pytest/scm.patch b/user/py3-pytest/scm.patch
index 799eefac0..ef45821cd 100644
--- a/user/py3-pytest/scm.patch
+++ b/user/py3-pytest/scm.patch
@@ -1,13 +1,12 @@
---- pytest-3.9.1/setup.py 2018-10-16 15:46:37.000000000 -0400
-+++ pytest-3.9.1/setup.py 2018-10-22 19:32:49.261592294 -0400
-@@ -25,8 +25,8 @@ if "_PYTEST_SETUP_SKIP_PLUGGY_DEP" not i
-
+--- pytest-5.0.1/setup.py 2019-07-05 07:12:59.000000000 -0400
++++ pytest-5.0.1/setup.py 2019-08-06 08:09:07.890005143 -0400
+@@ -19,7 +19,8 @@ INSTALL_REQUIRES = [
def main():
setup(
-- use_scm_version={"write_to": "src/_pytest/_version.py"},
-- setup_requires=["setuptools-scm", "setuptools>=30.3"],
-+ setup_requires=["setuptools>=30.3"],
-+ version="3.9.1",
+ use_scm_version={"write_to": "src/_pytest/_version.py"},
+- setup_requires=["setuptools-scm", "setuptools>=40.0"],
++ setup_requires=["setuptools>=40.0"],
++ version="5.0.1",
package_dir={"": "src"},
- install_requires=INSTALL_REQUIRES,
- )
+ # fmt: off
+ extras_require={