summaryrefslogtreecommitdiff
path: root/user/py3-pyyaml
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2019-03-17 09:23:46 -0700
committerzlg <zlg@zlg.space>2019-03-17 09:23:46 -0700
commit0d4e2360949b255c0cb8a376ee33a7d60ec55150 (patch)
tree767f74b3afa38a6c13c6620433e6f95a53efab6f /user/py3-pyyaml
parentaff794849f6e35bb398de968aa3965401f4b057e (diff)
downloadpackages-0d4e2360949b255c0cb8a376ee33a7d60ec55150.tar.gz
packages-0d4e2360949b255c0cb8a376ee33a7d60ec55150.tar.bz2
packages-0d4e2360949b255c0cb8a376ee33a7d60ec55150.tar.xz
packages-0d4e2360949b255c0cb8a376ee33a7d60ec55150.zip
user/py3-pyyaml: bump to v5.1
This version introduces some API-breaking changes, and its build system wants Cython to generate the .c file needed to build the module in C. It falls back to pure Python at present, and passes all of its tests. Once we get Cython (or find out why it's not writing the .c file), it'll be fine.
Diffstat (limited to 'user/py3-pyyaml')
-rw-r--r--user/py3-pyyaml/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/py3-pyyaml/APKBUILD b/user/py3-pyyaml/APKBUILD
index 8af1d75f1..6dece19c3 100644
--- a/user/py3-pyyaml/APKBUILD
+++ b/user/py3-pyyaml/APKBUILD
@@ -1,21 +1,23 @@
# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-pyyaml
-_pkgname=PyYAML
-pkgver=3.13
+_pkgname=pyyaml
+pkgver=5.1
pkgrel=0
pkgdesc="YAML parser and emitter for Python"
url="https://pyyaml.org/wiki/PyYAML"
-arch="all"
+arch="noarch"
license="MIT"
depends="python3 yaml"
makedepends="python3-dev yaml yaml-dev"
subpackages=""
-source="http://pyyaml.org/download/pyyaml/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/yaml/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
+ # Seems like they need Cython to build the C extension now, so it falls back to pure Python.
+ # Once we ship Cython we can probably change this.
python3 setup.py build
}
@@ -29,4 +31,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="93642286d0317e2fe970632c36d38ce6030f7cabcf971f28e3a1054f07390fcee5baaf7f167e7c9690dbd7b2adc61f5b7d75a218ace0abca34ff8815486cfdd7 PyYAML-3.13.tar.gz"
+sha512sums="e49f593b9f60018efa19629b902ad1e56f79537106a4cd019baa324a74a8af7563d294db012280261fc7fa9d686dd5af656e22fb4bf6a6ccfd0084515b9591d5 py3-pyyaml-5.1.tar.gz"