summaryrefslogtreecommitdiff
path: root/user/py3-setuptools/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-05-22 00:48:43 -0400
committerMax Rees <maxcrees@me.com>2018-05-22 00:48:43 -0400
commit30c3def0481fc6aaf0c10cae8038b43c50bd8b0c (patch)
tree93ae4c8937e6264b691ac972de45ef777075604d /user/py3-setuptools/APKBUILD
parentf2cdafca7de3fe5cd6bed4da6e8d8d594c8dc93e (diff)
downloadpackages-30c3def0481fc6aaf0c10cae8038b43c50bd8b0c.tar.gz
packages-30c3def0481fc6aaf0c10cae8038b43c50bd8b0c.tar.bz2
packages-30c3def0481fc6aaf0c10cae8038b43c50bd8b0c.tar.xz
packages-30c3def0481fc6aaf0c10cae8038b43c50bd8b0c.zip
user/py3-setuptools: bump to 39.1.0
Commits: https://github.com/pypa/setuptools/compare/v39.0.1...v39.1.0 Changelog: https://github.com/pypa/setuptools/blob/v39.1.0/CHANGES.rst#v3910
Diffstat (limited to 'user/py3-setuptools/APKBUILD')
-rw-r--r--user/py3-setuptools/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
index ed0269de7..6bee60420 100644
--- a/user/py3-setuptools/APKBUILD
+++ b/user/py3-setuptools/APKBUILD
@@ -2,21 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-setuptools
_pkgname=setuptools
-pkgver=39.0.1
-pkgrel=1
+pkgver=39.1.0
+pkgrel=0
pkgdesc="A collection of enhancements to the Python distutils"
url="http://pypi.python.org/project/setuptools"
arch="noarch"
license="MIT"
depends="python3"
makedepends="python3-dev"
-#checkdepends="py3-tox"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
+checkdepends="py3-tox"
+options="net" # Circular dependency with py3-tox. Passes on x86_64
subpackages="py3-easy_install:easy_install"
-# Note: PyPI download is missing tests/requirements.txt
-source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz
- pythonpath.patch
- update-wheel-tests.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pythonpath.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -42,6 +40,5 @@ easy_install() {
mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
}
-sha512sums="34df8f10e89825975c82059c759690a2cc1486fc84c71a76875b92c2452529fbdd628e11e3043e479ea3f031af18b37a37b86d2a8d2505c300188eccdc109332 py3-setuptools-39.0.1.tar.gz
-0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch
-5262d1dcdbf8ab40eb4e9fde3e8496e6b4e9809d6056e6069fc11ef5390e064dfef9f7eccec3452e7566b88ab861bf544b57dce249c4291142f307bd6465e45a update-wheel-tests.patch"
+sha512sums="9fa00930a1923782c2f6356bf992410d42b3dd81b5a673e2957eaf8941787fbea324851c5df48e37601641d004ee900c88a1cfa97ef9df374879586a36efa5c6 py3-setuptools-39.1.0.tar.gz
+ee248df4174240e90a35190e0a47bf0fa4cc5601adc64eff5fd585c8919e47c3a2bb6191b8333800016567d8a0f0f71b7c2306779ea7e4ab7c8951bdee28ef5e pythonpath.patch"