summaryrefslogtreecommitdiff
path: root/user/py3-sortedcontainers/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/py3-sortedcontainers/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/py3-sortedcontainers/APKBUILD')
-rw-r--r--user/py3-sortedcontainers/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-sortedcontainers/APKBUILD b/user/py3-sortedcontainers/APKBUILD
new file mode 100644
index 000000000..b14785965
--- /dev/null
+++ b/user/py3-sortedcontainers/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-sortedcontainers
+_pkgname=sortedcontainers
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Sorted container objects for Python 3"
+url="https://pypi.python.org/pypi/sortedcontainers"
+arch="noarch"
+options="!check" # See checkdepends comment below.
+license="Apache-2.0"
+depends="python3"
+# requires unpackaged filelock, toml; requires importlib_metadata<1
+#checkdepends="py3-importlib_metadata py3-packaging py3-tox"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="6fe2b6e7d030b67aa990d62160079852feaee7828164eae03a6477dc1704863f6ed0daadb44dc919653c66996d51f833b5858351a8fd5ad28998f8010a8ca1a4 py3-sortedcontainers-2.1.0.tar.gz"