summaryrefslogtreecommitdiff
path: root/user/py3-sortedcontainers
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 21:36:42 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 21:36:53 -0600
commit998aade99859684687f2b84fb72d88b2f6996367 (patch)
tree6c00c69080d26ad5dcf7f7f05ed7caa60a02cc7c /user/py3-sortedcontainers
parent669073072e824b995fb2ef1c2326ee2eb92fc673 (diff)
downloadpackages-998aade99859684687f2b84fb72d88b2f6996367.tar.gz
packages-998aade99859684687f2b84fb72d88b2f6996367.tar.bz2
packages-998aade99859684687f2b84fb72d88b2f6996367.tar.xz
packages-998aade99859684687f2b84fb72d88b2f6996367.zip
user/py3-sortedcontainers: here we are now, in containers
Required for py3-hypothesis bump.
Diffstat (limited to 'user/py3-sortedcontainers')
-rw-r--r--user/py3-sortedcontainers/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/py3-sortedcontainers/APKBUILD b/user/py3-sortedcontainers/APKBUILD
new file mode 100644
index 000000000..b14785965
--- /dev/null
+++ b/user/py3-sortedcontainers/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-sortedcontainers
+_pkgname=sortedcontainers
+_p="${_pkgname#?}"
+_p="${_pkgname%"$_p"}"
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Sorted container objects for Python 3"
+url="https://pypi.python.org/pypi/sortedcontainers"
+arch="noarch"
+options="!check" # See checkdepends comment below.
+license="Apache-2.0"
+depends="python3"
+# requires unpackaged filelock, toml; requires importlib_metadata<1
+#checkdepends="py3-importlib_metadata py3-packaging py3-tox"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+}
+
+sha512sums="6fe2b6e7d030b67aa990d62160079852feaee7828164eae03a6477dc1704863f6ed0daadb44dc919653c66996d51f833b5858351a8fd5ad28998f8010a8ca1a4 py3-sortedcontainers-2.1.0.tar.gz"