summaryrefslogtreecommitdiff
path: root/user/py3-sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 22:15:25 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-26 22:15:25 -0600
commit9b07de55dfe6d50baeda3a8feda7f9fcade9c647 (patch)
tree91e144d369aca131b43dd8ad49113eb7392912ca /user/py3-sphinxcontrib-qthelp
parent09427d6fc6905f67965861a01ed0e20f456aebc5 (diff)
downloadpackages-9b07de55dfe6d50baeda3a8feda7f9fcade9c647.tar.gz
packages-9b07de55dfe6d50baeda3a8feda7f9fcade9c647.tar.bz2
packages-9b07de55dfe6d50baeda3a8feda7f9fcade9c647.tar.xz
packages-9b07de55dfe6d50baeda3a8feda7f9fcade9c647.zip
user/py3*: modernise, fix syntax
Diffstat (limited to 'user/py3-sphinxcontrib-qthelp')
-rw-r--r--user/py3-sphinxcontrib-qthelp/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/py3-sphinxcontrib-qthelp/APKBUILD b/user/py3-sphinxcontrib-qthelp/APKBUILD
index fb32bad02..3740f30ff 100644
--- a/user/py3-sphinxcontrib-qthelp/APKBUILD
+++ b/user/py3-sphinxcontrib-qthelp/APKBUILD
@@ -12,23 +12,20 @@ arch="noarch"
options="!check" # Cyclic dependency with sphinx
license="BSD-2-Clause"
depends="python3"
-makedepends="python3-dev"
checkdepends="py3-sphinx py3-pytest"
+makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
PYTHONWARNINGS="all,ignore::DeprecationWarning:docutils.io" pytest --durations 25
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}