summaryrefslogtreecommitdiff
path: root/user/py3-twisted
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-15 00:00:10 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-15 00:07:44 +0000
commitea8696de9f1f6650449fad032d42143262cfcf0b (patch)
treeba16e77066d14da8b2c3493613b3a1e73012e097 /user/py3-twisted
parent77a04e26a835db3ab05f2fa2c9e9b25b255c2f96 (diff)
downloadpackages-ea8696de9f1f6650449fad032d42143262cfcf0b.tar.gz
packages-ea8696de9f1f6650449fad032d42143262cfcf0b.tar.bz2
packages-ea8696de9f1f6650449fad032d42143262cfcf0b.tar.xz
packages-ea8696de9f1f6650449fad032d42143262cfcf0b.zip
user/py3-twisted: new package
Diffstat (limited to 'user/py3-twisted')
-rw-r--r--user/py3-twisted/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-twisted/APKBUILD b/user/py3-twisted/APKBUILD
new file mode 100644
index 000000000..e9d38cf7a
--- /dev/null
+++ b/user/py3-twisted/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=py3-twisted
+_pkgname=Twisted
+pkgver=18.9.0
+pkgrel=0
+pkgdesc="Asynchronous networking framework written in Python"
+url="https://twistedmatrix.com/"
+arch="all"
+license="MIT"
+depends="py3-incremental"
+makedepends="python3-dev"
+subpackages=""
+source="https://files.pythonhosted.org/packages/5d/0e/a72d85a55761c2c3ff1cb968143a2fd5f360220779ed90e0fadf4106d4f2/Twisted-$pkgver.tar.bz2"
+builddir="$srcdir/Twisted-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a9878750f46207b8758f5407a0e4332d9e367bd3ed4e18001825982c3ba78c56372934e634f1866805b9b9bc452698ad36396285172b61cf84da0de5efa7cc29 Twisted-18.9.0.tar.bz2"