summaryrefslogtreecommitdiff
path: root/user/py3-zope-deprecation
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2019-01-02 19:39:03 -0800
committerzlg <zlg@zlg.space>2019-01-02 19:39:03 -0800
commit6a3a2e4b050a2716733a9aadbfbc664f0512441c (patch)
treebe50a53d151b4368d8fcf64a63068bfb149fae09 /user/py3-zope-deprecation
parent9cfafeb76d5c0111e7df86a93c156f29fb65efad (diff)
downloadpackages-6a3a2e4b050a2716733a9aadbfbc664f0512441c.tar.gz
packages-6a3a2e4b050a2716733a9aadbfbc664f0512441c.tar.bz2
packages-6a3a2e4b050a2716733a9aadbfbc664f0512441c.tar.xz
packages-6a3a2e4b050a2716733a9aadbfbc664f0512441c.zip
user/py3-zope-deprecation: new package
Diffstat (limited to 'user/py3-zope-deprecation')
-rw-r--r--user/py3-zope-deprecation/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/py3-zope-deprecation/APKBUILD b/user/py3-zope-deprecation/APKBUILD
new file mode 100644
index 000000000..f21a1fdeb
--- /dev/null
+++ b/user/py3-zope-deprecation/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer: zlg <zlg+adelie@zlg.space>
+pkgname=py3-zope-deprecation
+_pkgname=zope.deprecation
+pkgver=4.4.0
+pkgrel=0
+pkgdesc="A function to mark deprecated parts of an API"
+url="https://github.com/zopefoundation/zope.deprecation"
+arch="noarch"
+options="!check" # needs zope.testrunner
+license="ZPL-2.1"
+depends="python3"
+makedepends="python3-dev"
+subpackages=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/$_pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d8632a3442eee059383014bb3341b30897ad8f9206b71bc586c873c4cccf5f87296edaf18f1e1c93878f480e3b0e8e1c1936ac19ed327f4ab227402ebbc73e0e zope.deprecation-4.4.0.tar.gz"