summaryrefslogtreecommitdiff
path: root/user/py3-zope-hookable/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-08-06 12:38:54 -0500
committerMax Rees <maxcrees@me.com>2019-08-06 20:45:50 -0500
commitf8a53e5ac86e9a6744176a23762a84375125b6b9 (patch)
treeeef975fddac1c6c1939b9524f5f2bd307e927938 /user/py3-zope-hookable/APKBUILD
parentced40a0c63327d3d8ae269dd3b9023f5e54488a0 (diff)
downloadpackages-f8a53e5ac86e9a6744176a23762a84375125b6b9.tar.gz
packages-f8a53e5ac86e9a6744176a23762a84375125b6b9.tar.bz2
packages-f8a53e5ac86e9a6744176a23762a84375125b6b9.tar.xz
packages-f8a53e5ac86e9a6744176a23762a84375125b6b9.zip
user/py3-zope-hookable: enable unit tests, drop unnecessary deps
Installed version does not depend on tox nor coverage
Diffstat (limited to 'user/py3-zope-hookable/APKBUILD')
-rw-r--r--user/py3-zope-hookable/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/user/py3-zope-hookable/APKBUILD b/user/py3-zope-hookable/APKBUILD
index 454d1c46e..dcda3dde3 100644
--- a/user/py3-zope-hookable/APKBUILD
+++ b/user/py3-zope-hookable/APKBUILD
@@ -3,25 +3,27 @@
pkgname=py3-zope-hookable
_pkgname=zope.hookable
pkgver=4.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="A library that provides an interface for hookable functions"
url="https://github.com/zopefoundation/zope.hookable"
arch="all"
-options="!check" # needs zope.testing
+# Certified net clean
license="ZPL-2.1"
depends="python3"
-makedepends="python3-dev py3-tox coverage"
+makedepends="python3-dev"
subpackages=""
source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}