summaryrefslogtreecommitdiff
path: root/user/qt-creator
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-22 01:34:45 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-22 03:14:38 -0600
commitbdd71ef51bdd0b679a1384d3d8cce744ab2c9cc0 (patch)
tree02d73ce75d3c407c4ff073f63c2e2c221827de6a /user/qt-creator
parentb8ab04302be9c01e8d4d93afad294a3a3261ac9a (diff)
downloadpackages-bdd71ef51bdd0b679a1384d3d8cce744ab2c9cc0.tar.gz
packages-bdd71ef51bdd0b679a1384d3d8cce744ab2c9cc0.tar.bz2
packages-bdd71ef51bdd0b679a1384d3d8cce744ab2c9cc0.tar.xz
packages-bdd71ef51bdd0b679a1384d3d8cce744ab2c9cc0.zip
user/qt-creator: Update to 4.15.2
Backport some fixes for LLVM 14 compatibility. Closes: #808
Diffstat (limited to 'user/qt-creator')
-rw-r--r--user/qt-creator/APKBUILD13
-rw-r--r--user/qt-creator/llvm13.patch71
-rw-r--r--user/qt-creator/malloc_trim.patch12
3 files changed, 92 insertions, 4 deletions
diff --git a/user/qt-creator/APKBUILD b/user/qt-creator/APKBUILD
index dbe83e008..7ef7f7671 100644
--- a/user/qt-creator/APKBUILD
+++ b/user/qt-creator/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt-creator
-pkgver=4.12.4
+pkgver=4.15.2
pkgrel=0
pkgdesc="Cross-platform multi-language programming IDE"
url="https://doc.qt.io/qtcreator/index.html"
@@ -10,10 +10,13 @@ options="!check" # No test suite.
license="LGPL-2.0 WITH Qt-LGPL-exception-1.1"
depends="qt5-qtquickcontrols"
makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtserialport-dev
- qt5-qtscript-dev qt5-qttools-dev clang-dev llvm8-dev python3
+ qt5-qtscript-dev qt5-qttools-dev clang-dev llvm14-dev python3
libexecinfo-dev"
subpackages="$pkgname-dev"
-source="https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.gz"
+source="https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/$pkgname-opensource-src-$pkgver.tar.xz
+ llvm13.patch
+ malloc_trim.patch
+ "
ldpath="/usr/lib/qtcreator"
builddir="$srcdir/$pkgname-opensource-src-$pkgver"
@@ -27,4 +30,6 @@ package() {
make install INSTALL_ROOT="$pkgdir"/usr
}
-sha512sums="137fda4882bce31b2844c6a4c1d54f5628f0812611266b2d7f74d6c155bec97809f50dca4a253c5d9686e7d0838ee568d054e5102333c63c30ca430f50370013 qt-creator-opensource-src-4.12.4.tar.gz"
+sha512sums="b29d5d97a1faa8d5756069d90c18d6d367e09057b97bd75c774bc2d1e373f9f4dcc24211188259f8d397bb932a65daaacda433bced796fd165654f5c3c621258 qt-creator-opensource-src-4.15.2.tar.xz
+c38cf1aea69bc52864d5aa4b6fbc01b5e91b1514a616056b270fcccc2744bb418eb93a470462823c05e00e44f44c45d8e26effd8aa72a6817402ddd9a6dd0cc4 llvm13.patch
+7fcb9b293daecc4c0f294d372507db9a6282479c4cf45999446193d9f35552db2532d47dedc9c5666a10855e20d0fe655f0ee0408abca8cc8ffbf121a230960f malloc_trim.patch"
diff --git a/user/qt-creator/llvm13.patch b/user/qt-creator/llvm13.patch
new file mode 100644
index 000000000..b4a6998d8
--- /dev/null
+++ b/user/qt-creator/llvm13.patch
@@ -0,0 +1,71 @@
+From 14eb5b382cabf90352634393c19bf87a4c15766a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Mon, 8 Mar 2021 21:56:06 +0100
+Subject: [PATCH] clangformat: Fix build with LLVM 13
+
+Change-Id: I5eaad17a6f240aa1e3f246492b69f093b4f59fee
+Reviewed-by: David Schulz <david.schulz@qt.io>
+---
+ src/plugins/clangformat/clangformatbaseindenter.cpp | 4 ++++
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatbaseindenter.cpp b/src/plugins/clangformat/clangformatbaseindenter.cpp
+index fb8e6938096..6378b2af530 100644
+--- a/src/plugins/clangformat/clangformatbaseindenter.cpp
++++ b/src/plugins/clangformat/clangformatbaseindenter.cpp
+@@ -42,7 +42,11 @@ void adjustFormatStyleForLineBreak(clang::format::FormatStyle &style,
+ ReplacementsToKeep replacementsToKeep)
+ {
+ style.MaxEmptyLinesToKeep = 100;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SortIncludes = clang::format::FormatStyle::SI_Never;
++#else
+ style.SortIncludes = false;
++#endif
+ style.SortUsingDeclarations = false;
+
+ // This is a separate pass, don't do it unless it's the full formatting.
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index a249327d0ed..770e75908c8 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -145,7 +145,11 @@ static clang::format::FormatStyle qtcStyle()
+ style.PenaltyReturnTypeOnItsOwnLine = 300;
+ style.PointerAlignment = FormatStyle::PAS_Right;
+ style.ReflowComments = false;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SortIncludes = FormatStyle::SI_CaseSensitive;
++#else
+ style.SortIncludes = true;
++#endif
+ style.SortUsingDeclarations = true;
+ style.SpaceAfterCStyleCast = true;
+ style.SpaceAfterTemplateKeyword = false;
+From 55b91a76172a3235b4879daf0b675519d5b02db7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Wed, 16 Jun 2021 20:59:29 +0200
+Subject: [PATCH] clangformat: Fix build with LLVM 13
+
+Change-Id: Ia9db10696fd129c8b989ecc4c9ecbb7f1f10e68c
+Reviewed-by: David Schulz <david.schulz@qt.io>
+---
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index 2f9a306b99c..3905ae5f6a5 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -157,7 +157,11 @@ static clang::format::FormatStyle qtcStyle()
+ style.SpaceBeforeParens = FormatStyle::SBPO_ControlStatements;
+ style.SpaceInEmptyParentheses = false;
+ style.SpacesBeforeTrailingComments = 1;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SpacesInAngles = FormatStyle::SIAS_Never;
++#else
+ style.SpacesInAngles = false;
++#endif
+ style.SpacesInContainerLiterals = false;
+ style.SpacesInCStyleCastParentheses = false;
+ style.SpacesInParentheses = false;
diff --git a/user/qt-creator/malloc_trim.patch b/user/qt-creator/malloc_trim.patch
new file mode 100644
index 000000000..f7a012750
--- /dev/null
+++ b/user/qt-creator/malloc_trim.patch
@@ -0,0 +1,12 @@
+malloc_trim is not available on musl and it isn't needed anyway.
+--- qt-creator-opensource-src-4.15.2/src/app/main.cpp.old 2021-07-12 21:12:53.000000000 -0500
++++ qt-creator-opensource-src-4.15.2/src/app/main.cpp 2022-11-22 00:29:21.110626363 -0600
+@@ -782,7 +782,7 @@
+ // shutdown plugin manager on the exit
+ QObject::connect(&app, &QCoreApplication::aboutToQuit, &pluginManager, &PluginManager::shutdown);
+
+-#ifdef Q_OS_LINUX
++#if defined(Q_OS_LINUX) && defined(__GLIBC__)
+ class MemoryTrimmer : public QObject
+ {
+ public: