summaryrefslogtreecommitdiff
path: root/user/qt5-qtpositioning
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-16 04:39:46 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-16 04:39:46 -0500
commitfde9480ee878da11ee6a397b08c1d9064fb64bde (patch)
tree4db7ac27bee0e862bc7655505f394581e89794df /user/qt5-qtpositioning
parent44d8df53c1fa631897a0935a0a7889a9e6ac0f84 (diff)
downloadpackages-fde9480ee878da11ee6a397b08c1d9064fb64bde.tar.gz
packages-fde9480ee878da11ee6a397b08c1d9064fb64bde.tar.bz2
packages-fde9480ee878da11ee6a397b08c1d9064fb64bde.tar.xz
packages-fde9480ee878da11ee6a397b08c1d9064fb64bde.zip
user/qt5-qtpositioning: new package
Diffstat (limited to 'user/qt5-qtpositioning')
-rw-r--r--user/qt5-qtpositioning/APKBUILD37
-rw-r--r--user/qt5-qtpositioning/no-getting-thread-names.patch12
2 files changed, 49 insertions, 0 deletions
diff --git a/user/qt5-qtpositioning/APKBUILD b/user/qt5-qtpositioning/APKBUILD
new file mode 100644
index 000000000..e2fc9f64b
--- /dev/null
+++ b/user/qt5-qtpositioning/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtpositioning
+_pkgname=qtlocation-opensource-src
+pkgver=5.9.6
+pkgrel=0
+pkgdesc="Qt 5 - Geolocation services"
+url="https://qt.io/"
+arch="all"
+options="!check"
+license="LGPLv2 with exceptions OR GPLv3 with exceptions"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ no-getting-thread-names.patch
+ "
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake
+ # too memory hungry
+ if [ -z "$JOBS" -o $JOBS -gt 16 ]; then
+ make -j16
+ else
+ make
+ fi
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="63071f88b6b742701a0f26a11edb20e50a7a9f158c8a79dcdfd39668197963e5d505a1de828acad273ebc54f15f51fa1089ed03953cc46ca9c68ddad647ac06a qtlocation-opensource-src-5.9.6.tar.xz
+8590335ae90ade1c685ff99fb4319d1b7448d2ae15ba999e3dc9a29e62eda3db587d8ee366dc68fad6eb9e0872532d50f0bdc74f4689a554ca095ad24967418c no-getting-thread-names.patch"
diff --git a/user/qt5-qtpositioning/no-getting-thread-names.patch b/user/qt5-qtpositioning/no-getting-thread-names.patch
new file mode 100644
index 000000000..63aa8f66c
--- /dev/null
+++ b/user/qt5-qtpositioning/no-getting-thread-names.patch
@@ -0,0 +1,12 @@
+--- qtlocation-opensource-src-5.9.6/src/3rdparty/mapbox-gl-native/platform/default/thread.cpp.old 2017-11-29 18:38:56.000000000 +0000
++++ qtlocation-opensource-src-5.9.6/src/3rdparty/mapbox-gl-native/platform/default/thread.cpp 2018-07-16 09:24:16.990000000 +0000
+@@ -11,7 +11,9 @@
+
+ std::string getCurrentThreadName() {
+ char name[32] = "unknown";
++#ifdef __GLIBC__
+ pthread_getname_np(pthread_self(), name, sizeof(name));
++#endif
+
+ return name;
+ }