summaryrefslogtreecommitdiff
path: root/user/qt5-qtsvg
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-27 04:02:42 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-27 04:02:42 -0600
commit47d18b13213ccd7c51894796760f97571c3eb424 (patch)
tree6e31cc5d066c199564a5c8f34a40d313a08c44aa /user/qt5-qtsvg
parent9b07de55dfe6d50baeda3a8feda7f9fcade9c647 (diff)
downloadpackages-47d18b13213ccd7c51894796760f97571c3eb424.tar.gz
packages-47d18b13213ccd7c51894796760f97571c3eb424.tar.bz2
packages-47d18b13213ccd7c51894796760f97571c3eb424.tar.xz
packages-47d18b13213ccd7c51894796760f97571c3eb424.zip
user/qt5: Bump to 5.12.6 LTS
This updates Qt 5 to the latest LTS release available. Notable changes: * The infamous clipboard bug (upstream QTBUG-65145; Gerrit 254187) is fixed! * Qt Declarative's "V4 JIT" is disabled globally on pmmx. It is no longer (easily) possible to turn off the JIT selectively based on CPU capability. * Qt Script builds correctly on GCC 8 now. This does not include: * Build testing of Qt Multimedia (yet); this depends on the time64-isation of the alsa-lib package (at least). * Build testing of Qt Speech (yet); speech-dispatcher also deps on alsa-lib indirectly. * Qt WebKit 5.212. This will be committed later.
Diffstat (limited to 'user/qt5-qtsvg')
-rw-r--r--user/qt5-qtsvg/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/user/qt5-qtsvg/APKBUILD b/user/qt5-qtsvg/APKBUILD
index d0c96bdc6..ec6aaa074 100644
--- a/user/qt5-qtsvg/APKBUILD
+++ b/user/qt5-qtsvg/APKBUILD
@@ -1,31 +1,28 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt5-qtsvg
-_pkgname=qtsvg-opensource-src
-pkgver=5.9.7
+_pkgname=qtsvg-everywhere-src
+pkgver=5.12.6
pkgrel=0
-pkgdesc="Qt 5 - SVG rendering library"
+pkgdesc="Qt SVG rendering library"
url="https://www.qt.io/"
arch="all"
-license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
makedepends="qt5-qtbase-dev zlib-dev"
subpackages="$pkgname-dev"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
qmake
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install INSTALL_ROOT="$pkgdir"
}
-sha512sums="d2e58ff0321fd40031dbbc0d0b0a8bb321cae2dc64bb4afec3c72ed9b5a25d67b156971d7a5ea4f74d966a3e8cda779474ee932ab129fa0b26f12978feebcd84 qtsvg-opensource-src-5.9.7.tar.xz"
+sha512sums="a0200f38566ba526a9366c0b240d4e3e0ba0662209fa1225145d3c2f2f371c77ba804239f96a6d351f117413240adce17c53f16205285d6aed6978bc5435a942 qtsvg-everywhere-src-5.12.6.tar.xz"