summaryrefslogtreecommitdiff
path: root/user/qt5-qtwebkit
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-01 06:36:18 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-01 06:36:18 +0000
commit7fe4e2804e380d669842feaedcdd3439cbc41dbc (patch)
treeeef8d3027f5b099098e27e9f6db079f93cde1d9f /user/qt5-qtwebkit
parent3e64ad1fb1b9c43071fab0f5e0f1f64e8d609436 (diff)
downloadpackages-7fe4e2804e380d669842feaedcdd3439cbc41dbc.tar.gz
packages-7fe4e2804e380d669842feaedcdd3439cbc41dbc.tar.bz2
packages-7fe4e2804e380d669842feaedcdd3439cbc41dbc.tar.xz
packages-7fe4e2804e380d669842feaedcdd3439cbc41dbc.zip
user/qt5-qtwebkit: add comment to not touch -g0 on pmmx
Diffstat (limited to 'user/qt5-qtwebkit')
-rw-r--r--user/qt5-qtwebkit/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/user/qt5-qtwebkit/APKBUILD b/user/qt5-qtwebkit/APKBUILD
index b2a408ddb..37eb11b1c 100644
--- a/user/qt5-qtwebkit/APKBUILD
+++ b/user/qt5-qtwebkit/APKBUILD
@@ -38,9 +38,13 @@ build() {
local _maybe_smaller=""
cd "$builddir"
+ # On 32-bit x86, ld.bfd will run out of memory if debugging information
+ # is built. See https://sourceware.org/bugzilla/show_bug.cgi?id=23470
+ # for more information.
case "$CARCH" in
pmmx) _maybe_smaller="QMAKE_CXXFLAGS_DEBUG+=-g0"
esac
+
qmake $_maybe_smaller
# /usr/include/fortify/stdlib.h:20:25: fatal error: stdlib.h: No such file or directory