summaryrefslogtreecommitdiff
path: root/user/rasqal
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-08-11 19:43:59 -0400
committerMax Rees <maxcrees@me.com>2018-08-11 19:43:59 -0400
commitb48d46647ed485e6fd05cf812dd7570b310c17e8 (patch)
tree4fc82ee3f69f7db390a675c46217e5f696ffd282 /user/rasqal
parent73abe141125865fa78c3cffe516fe3c95caa4a11 (diff)
downloadpackages-b48d46647ed485e6fd05cf812dd7570b310c17e8.tar.gz
packages-b48d46647ed485e6fd05cf812dd7570b310c17e8.tar.bz2
packages-b48d46647ed485e6fd05cf812dd7570b310c17e8.tar.xz
packages-b48d46647ed485e6fd05cf812dd7570b310c17e8.zip
user/rasqal: pull in, fix license, add tests
Diffstat (limited to 'user/rasqal')
-rw-r--r--user/rasqal/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/user/rasqal/APKBUILD b/user/rasqal/APKBUILD
new file mode 100644
index 000000000..ddeb6bd5e
--- /dev/null
+++ b/user/rasqal/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=rasqal
+pkgver=0.9.33
+pkgrel=1
+pkgdesc="RDF query library"
+url="http://www.librdf.org/"
+arch="all"
+license="(LGPL-2.1+ OR GPL-2.0+ OR Apache-2.0+) AND Unlicense AND Public-Domain"
+depends=""
+depends_dev="raptor2-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.librdf.org/source/$pkgname-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --target=$CTARGET \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="05728682797470db9e51d156012e8fde9dec1554d107372faa11cbe6cdc3356e92386f4f8de6d7c41e3100b76f9b1c6809102a913829cddbd2ff29043c04d522 rasqal-0.9.33.tar.gz"