summaryrefslogtreecommitdiff
path: root/user/rust/0025-Ignore-broken-and-non-applicable-tests.patch
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2018-10-06 04:22:05 +0000
committerSamuel Holland <samuel@sholland.org>2018-10-09 04:28:15 +0000
commit2323b0da26e293bb4d5a7a4ad8afed85a599d11d (patch)
treed67f5276d8d72c2fe2caa2e4e5756c14848d9f91 /user/rust/0025-Ignore-broken-and-non-applicable-tests.patch
parent49cec2be42835f6b4c5ff1bad4710e20db422b87 (diff)
downloadpackages-2323b0da26e293bb4d5a7a4ad8afed85a599d11d.tar.gz
packages-2323b0da26e293bb4d5a7a4ad8afed85a599d11d.tar.bz2
packages-2323b0da26e293bb4d5a7a4ad8afed85a599d11d.tar.xz
packages-2323b0da26e293bb4d5a7a4ad8afed85a599d11d.zip
user/rust: Bump to 1.29.1 plus fixes for i586, ppc32
Diffstat (limited to 'user/rust/0025-Ignore-broken-and-non-applicable-tests.patch')
-rw-r--r--user/rust/0025-Ignore-broken-and-non-applicable-tests.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/user/rust/0025-Ignore-broken-and-non-applicable-tests.patch b/user/rust/0025-Ignore-broken-and-non-applicable-tests.patch
new file mode 100644
index 000000000..12c3e46dd
--- /dev/null
+++ b/user/rust/0025-Ignore-broken-and-non-applicable-tests.patch
@@ -0,0 +1,48 @@
+From 72a9bf3841f3c07db121f6d41ccd448d73aa1c01 Mon Sep 17 00:00:00 2001
+From: Samuel Holland <samuel@sholland.org>
+Date: Sun, 16 Sep 2018 16:38:48 +0000
+Subject: [PATCH 25/29] Ignore broken and non-applicable tests
+
+long-linker-command-lines: takes >10 minutes to run (but still passes)
+sparc-struct-abi: no sparc target
+sysroot-crates-are-unstable: can't run rustc without rpath
+---
+ src/test/codegen/sparc-struct-abi.rs | 1 +
+ src/test/run-make-fulldeps/long-linker-command-lines/Makefile | 1 -
+ src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile | 2 +-
+ 3 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/test/codegen/sparc-struct-abi.rs b/src/test/codegen/sparc-struct-abi.rs
+index d3b7a5cd59..5e0f94cdf9 100644
+--- a/src/test/codegen/sparc-struct-abi.rs
++++ b/src/test/codegen/sparc-struct-abi.rs
+@@ -12,6 +12,7 @@
+ // See issue #52638.
+
+ // compile-flags: -O --target=sparc64-unknown-linux-gnu --crate-type=rlib
++// ignore-test
+ #![feature(no_core, lang_items)]
+ #![no_core]
+
+diff --git a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
+index 5876fbc94b..e9f5c33b77 100644
+--- a/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
++++ b/src/test/run-make-fulldeps/long-linker-command-lines/Makefile
+@@ -2,4 +2,3 @@
+
+ all:
+ $(RUSTC) foo.rs -g -O
+- RUSTC="$(RUSTC_ORIGINAL)" $(call RUN,foo)
+diff --git a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+index 9e77070685..7784230b46 100644
+--- a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
++++ b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+@@ -1,4 +1,4 @@
+ -include ../tools.mk
+
+ all:
+- env '$(HOST_RPATH_ENV)' python2.7 test.py
++ true
+--
+2.18.0
+