summaryrefslogtreecommitdiff
path: root/user/rxvt-unicode
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-08-05 02:24:10 -0400
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-06 22:15:20 +0000
commitfb7f546314af4c6d2c3208d2aec3e9c772f9e704 (patch)
tree9774d4e29a31afcfca3df30d3fd25d6a2bf72637 /user/rxvt-unicode
parentd2a8114c7f803798fe6a4d8cdcf3b3ef50a3caf3 (diff)
downloadpackages-fb7f546314af4c6d2c3208d2aec3e9c772f9e704.tar.gz
packages-fb7f546314af4c6d2c3208d2aec3e9c772f9e704.tar.bz2
packages-fb7f546314af4c6d2c3208d2aec3e9c772f9e704.tar.xz
packages-fb7f546314af4c6d2c3208d2aec3e9c772f9e704.zip
user/rxvt-unicode: pull in, fix license
Diffstat (limited to 'user/rxvt-unicode')
-rw-r--r--user/rxvt-unicode/APKBUILD71
-rw-r--r--user/rxvt-unicode/gentables.patch8
-rw-r--r--user/rxvt-unicode/kerning.patch21
3 files changed, 100 insertions, 0 deletions
diff --git a/user/rxvt-unicode/APKBUILD b/user/rxvt-unicode/APKBUILD
new file mode 100644
index 000000000..f9c836dde
--- /dev/null
+++ b/user/rxvt-unicode/APKBUILD
@@ -0,0 +1,71 @@
+# Contributor: Moritz Wilhelmy
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Jakub Skrzypnik <j.skrzypnik@openmailbox.org>
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=rxvt-unicode
+pkgver=9.22
+pkgrel=4
+pkgdesc="Fork of the rxvt terminal emulator with improved unicode support"
+url="http://software.schmorp.de/pkg/rxvt-unicode.html"
+arch="all"
+options="!check" # No test suite.
+license="(GPL-2.0+ OR BSD-2-Clause) AND GPL-2.0+ AND GPL-3.0+"
+depends="$pkgname-terminfo"
+makedepends="libx11-dev libxft-dev ncurses fontconfig-dev
+ gdk-pixbuf-dev libxrender-dev perl-dev startup-notification-dev"
+subpackages="$pkgname-doc $pkgname-terminfo::noarch"
+source="http://dist.schmorp.de/$pkgname/$pkgname-$pkgver.tar.bz2
+ gentables.patch
+ kerning.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-terminfo=/usr/share/terminfo \
+ --enable-256-color \
+ --enable-font-styles \
+ --enable-xim \
+ --enable-keepscrolling \
+ --enable-selectionscrolling \
+ --enable-smart-resize \
+ --enable-pixbuf \
+ --enable-transparency \
+ --enable-frills \
+ --enable-perl \
+ --enable-mousewheel \
+ --enable-text-blink \
+ --enable-fading \
+ --enable-startup-notification \
+ --enable-unicode3 \
+ --disable-utmp \
+ --disable-wtmp \
+ --disable-lastlog
+ make
+}
+
+package() {
+ # despite having a separate terminfo subpackage
+ # TERMINFO env var is used by rxvt-unicode makefile
+ # leaving it as is ~skrzyp
+ export TERMINFO="$pkgdir/usr/share/terminfo"
+ mkdir -p "$TERMINFO"
+
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+terminfo() {
+ pkgdesc="$pkgdesc (terminfo data)"
+ depends=""
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/terminfo "$subpkgdir"/usr/share/terminfo
+}
+
+sha512sums="b39f1b2cbe6dd3fbd2a0ad6a9d391a2b6f49d7c5e67bc65fe44a9c86937f8db379572c67564c6e21ff6e09b447cdfd4e540544e486179e94da0e0db679c04dd9 rxvt-unicode-9.22.tar.bz2
+a45074b8fe39ffb712bd53b03521a8611fe5887a97ea09c1e85a7086de1042dd0360269803ffe5fcc56425af3c0cc3a55c214b2ef0fcfa2c3a298b4b37d261cb gentables.patch
+42314393f7f061f1aa2cf2fedd3d84e96d3104868b0629cefd9e9b313529afde52127a412992e76935fa2de8d4e685d6b5ce42162cb8d1b0365de63d10c11925 kerning.patch"
diff --git a/user/rxvt-unicode/gentables.patch b/user/rxvt-unicode/gentables.patch
new file mode 100644
index 000000000..577d0d78f
--- /dev/null
+++ b/user/rxvt-unicode/gentables.patch
@@ -0,0 +1,8 @@
+--- ./src/gentables.orig Wed Aug 4 04:59:09 2004
++++ ./src/gentables Tue Aug 10 00:03:21 2004
+@@ -1,4 +1,4 @@
+-#!/opt/bin/perl
++#!/usr/bin/perl
+
+ # the generated tables mostly have NOT been checked so far!
+
diff --git a/user/rxvt-unicode/kerning.patch b/user/rxvt-unicode/kerning.patch
new file mode 100644
index 000000000..a29a6f608
--- /dev/null
+++ b/user/rxvt-unicode/kerning.patch
@@ -0,0 +1,21 @@
+--- a/src/rxvtfont.C 2008-07-09 12:21:45.000000000 +0400
++++ b/src/rxvtfont.C 2009-10-30 14:32:53.000000000 +0300
+@@ -1195,12 +1195,14 @@
+ XGlyphInfo g;
+ XftTextExtents16 (disp, f, &ch, 1, &g);
+
+- g.width -= g.x;
+-
++/*
++ * bukind: don't use g.width as a width of a character!
++ * instead use g.xOff, see e.g.: http://keithp.com/~keithp/render/Xft.tutorial
++ */
+ int wcw = WCWIDTH (ch);
+- if (wcw > 0) g.width = (g.width + wcw - 1) / wcw;
++ if (wcw > 1) g.xOff = g.xOff / wcw;
++ if (width < g.xOff) width = g.xOff;
+
+- if (width < g.width ) width = g.width;
+ if (height < g.height ) height = g.height;
+ if (glheight < g.height - g.y) glheight = g.height - g.y;
+ }