summaryrefslogtreecommitdiff
path: root/user/s6-portable-utils
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2019-10-03 10:23:22 -0500
committerLaurent Bercot <ska-adelie@skarnet.org>2019-10-03 10:23:22 -0500
commit6989744a9f1085ff4ecd7d4317331e4c31c3b937 (patch)
tree9d69b147512b2aa07e2c70d5f9f9a5596d010f69 /user/s6-portable-utils
parent793ae86c5037247d96babf75e41e6c6b32b63cfd (diff)
downloadpackages-6989744a9f1085ff4ecd7d4317331e4c31c3b937.tar.gz
packages-6989744a9f1085ff4ecd7d4317331e4c31c3b937.tar.bz2
packages-6989744a9f1085ff4ecd7d4317331e4c31c3b937.tar.xz
packages-6989744a9f1085ff4ecd7d4317331e4c31c3b937.zip
user/s6-portable-utils: new package
Diffstat (limited to 'user/s6-portable-utils')
-rw-r--r--user/s6-portable-utils/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/user/s6-portable-utils/APKBUILD b/user/s6-portable-utils/APKBUILD
new file mode 100644
index 000000000..59ddf7559
--- /dev/null
+++ b/user/s6-portable-utils/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
+# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
+pkgname=s6-portable-utils
+pkgver=2.2.2.0
+pkgrel=0
+pkgdesc="skarnet.org's portable miscellaneous utilities"
+url="https://skarnet.org/software/s6-portable-utils/"
+arch="all"
+options="!check"
+license="ISC"
+_skalibs_version=2.9.0.0
+depends=
+makedepends="skalibs-dev>=$_skalibs_version skalibs-libs-dev>=$_skalibs_version"
+subpackages="$pkgname-doc"
+source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --disable-allstatic \
+ --prefix=/usr \
+ --with-dynlib=/lib
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+
+doc() {
+ pkgdesc="$pkgdesc (documentation)"
+ depends=
+ install_if="docs $pkgname=$pkgver-r$pkgrel"
+ mkdir -p "$subpkgdir/usr/share/doc"
+ cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
+}
+
+sha512sums="0f4400b00e44e984900e6a77fa326b91f472f3a97497d02549f3ec68f40d48438f37e574a3ee026498930449d8fd8de9a908923dcd58e1e99b58052f1fa35c40 s6-portable-utils-2.2.2.0.tar.gz"