summaryrefslogtreecommitdiff
path: root/user/sdl2
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-07 02:28:01 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-07 02:28:01 +0000
commit284a61f3e5681d32544223ea0b4ef7645b8ddf20 (patch)
tree310105757690f29d3c76e79814b836bf836fd3f7 /user/sdl2
parent7bd0b76c47c41ed2fc45f86d068c887474b1d1e5 (diff)
downloadpackages-284a61f3e5681d32544223ea0b4ef7645b8ddf20.tar.gz
packages-284a61f3e5681d32544223ea0b4ef7645b8ddf20.tar.bz2
packages-284a61f3e5681d32544223ea0b4ef7645b8ddf20.tar.xz
packages-284a61f3e5681d32544223ea0b4ef7645b8ddf20.zip
user/sdl2: fix C++ usage on PPC; add udev dynamic joystick support
Diffstat (limited to 'user/sdl2')
-rw-r--r--user/sdl2/APKBUILD11
-rw-r--r--user/sdl2/ensure-c++-on-ppc.patch14
2 files changed, 21 insertions, 4 deletions
diff --git a/user/sdl2/APKBUILD b/user/sdl2/APKBUILD
index 75b6b276f..45927c139 100644
--- a/user/sdl2/APKBUILD
+++ b/user/sdl2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=sdl2
pkgver=2.0.8
-pkgrel=0
+pkgrel=1
pkgdesc="Low level audio, keyboard, mouse, joystick and graphics library"
url="https://www.libsdl.org/"
arch="all"
@@ -10,9 +10,11 @@ license="zlib"
depends=""
makedepends="alsa-lib-dev libx11-dev libxcursor-dev libxext-dev libxi-dev
libxkbcommon-dev libxrandr-dev libxrender-dev libusb-dev mesa-dev
- libxscrnsaver-dev pulseaudio-dev"
+ libxscrnsaver-dev dbus-dev eudev-dev pulseaudio-dev"
subpackages="$pkgname-dev"
-source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz"
+source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz
+ ensure-c++-on-ppc.patch
+ "
builddir="$srcdir/SDL2-$pkgver"
build() {
@@ -41,4 +43,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869 SDL2-2.0.8.tar.gz"
+sha512sums="673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869 SDL2-2.0.8.tar.gz
+f64402503f4cf7e7d65efc1b397c9d632b0f592ee04893884155d0e88bc88e0ae096778cbd30a2caf61246430b43bd17a1f78dda8a8abcbc8ebd60ef107386ac ensure-c++-on-ppc.patch"
diff --git a/user/sdl2/ensure-c++-on-ppc.patch b/user/sdl2/ensure-c++-on-ppc.patch
new file mode 100644
index 000000000..03708c9b6
--- /dev/null
+++ b/user/sdl2/ensure-c++-on-ppc.patch
@@ -0,0 +1,14 @@
+On PowerPC systems, using SDL2 in a C++ codebase would FTBFS.
+
+--- SDL2-2.0.8/include/SDL_cpuinfo.h.old 2018-03-01 16:34:41.000000000 +0000
++++ SDL2-2.0.8/include/SDL_cpuinfo.h 2018-08-07 02:25:05.720000000 +0000
+@@ -53,6 +53,9 @@
+ #ifdef __ALTIVEC__
+ #if HAVE_ALTIVEC_H && !defined(__APPLE_ALTIVEC__) && !defined(SDL_DISABLE_ALTIVEC_H)
+ #include <altivec.h>
++#ifdef __cplusplus
++#undef vector
++#endif
+ #undef pixel
+ #undef bool
+ #endif