summaryrefslogtreecommitdiff
path: root/user/sdl2
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-08 08:16:01 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-08 08:16:01 +0000
commit39d1bb2bd8662ba307fee62ea4372015898152cc (patch)
tree8960adcc8e8eff1804b5c1dd14f7cebb9d4085c3 /user/sdl2
parent6ddc153486f536a781724ac7a1cf4a33c5fa0083 (diff)
downloadpackages-39d1bb2bd8662ba307fee62ea4372015898152cc.tar.gz
packages-39d1bb2bd8662ba307fee62ea4372015898152cc.tar.bz2
packages-39d1bb2bd8662ba307fee62ea4372015898152cc.tar.xz
packages-39d1bb2bd8662ba307fee62ea4372015898152cc.zip
user/sdl2: bump to 2.0.10
Diffstat (limited to 'user/sdl2')
-rw-r--r--user/sdl2/APKBUILD11
-rw-r--r--user/sdl2/ensure-c++-on-ppc.patch14
2 files changed, 3 insertions, 22 deletions
diff --git a/user/sdl2/APKBUILD b/user/sdl2/APKBUILD
index 910eb1763..0ba480012 100644
--- a/user/sdl2/APKBUILD
+++ b/user/sdl2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: August Klein <amatcoder@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=sdl2
-pkgver=2.0.9
+pkgver=2.0.10
pkgrel=0
pkgdesc="Low level audio, keyboard, mouse, joystick and graphics library"
url="https://www.libsdl.org/"
@@ -12,13 +12,10 @@ makedepends="alsa-lib-dev libx11-dev libxcursor-dev libxext-dev libxi-dev
libxkbcommon-dev libxrandr-dev libxrender-dev libusb-dev mesa-dev
libxscrnsaver-dev dbus-dev eudev-dev pulseaudio-dev"
subpackages="$pkgname-dev"
-source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz
- ensure-c++-on-ppc.patch
- "
+source="https://www.libsdl.org/release/SDL2-$pkgver.tar.gz"
builddir="$srcdir/SDL2-$pkgver"
build() {
- cd "$builddir"
# pmOS needs DirectFB for battery animations and LUKS unlocking
./configure \
--build=$CBUILD \
@@ -39,9 +36,7 @@ check() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="a78a4708b2bb5b35a7c7b7501eb3bd60a9aa3bb95a3d84e57763df4a377185e7312a94b66321eef7ca0d17255e4b402fc950e83ef0dbbd08f14ff1194107dc10 SDL2-2.0.9.tar.gz
-f64402503f4cf7e7d65efc1b397c9d632b0f592ee04893884155d0e88bc88e0ae096778cbd30a2caf61246430b43bd17a1f78dda8a8abcbc8ebd60ef107386ac ensure-c++-on-ppc.patch"
+sha512sums="f49b869362699b3282f6e82920e59c7fac581bcbf955f18a81cc126293c08093a90df7fcb39517cc8bc32708d2213fe645a42b655d6d811c1386efebb3d3c798 SDL2-2.0.10.tar.gz"
diff --git a/user/sdl2/ensure-c++-on-ppc.patch b/user/sdl2/ensure-c++-on-ppc.patch
deleted file mode 100644
index 03708c9b6..000000000
--- a/user/sdl2/ensure-c++-on-ppc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-On PowerPC systems, using SDL2 in a C++ codebase would FTBFS.
-
---- SDL2-2.0.8/include/SDL_cpuinfo.h.old 2018-03-01 16:34:41.000000000 +0000
-+++ SDL2-2.0.8/include/SDL_cpuinfo.h 2018-08-07 02:25:05.720000000 +0000
-@@ -53,6 +53,9 @@
- #ifdef __ALTIVEC__
- #if HAVE_ALTIVEC_H && !defined(__APPLE_ALTIVEC__) && !defined(SDL_DISABLE_ALTIVEC_H)
- #include <altivec.h>
-+#ifdef __cplusplus
-+#undef vector
-+#endif
- #undef pixel
- #undef bool
- #endif