summaryrefslogtreecommitdiff
path: root/user/sg3_utils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-09 20:56:47 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-09 20:56:47 +0000
commit4dd20482570e1e3c3cb4a7316067208c389baca6 (patch)
tree4848549f75be794a696b3e0838f85e91803186d0 /user/sg3_utils
parent3c13432e40343916eff89123bf10293bbfbb3904 (diff)
downloadpackages-4dd20482570e1e3c3cb4a7316067208c389baca6.tar.gz
packages-4dd20482570e1e3c3cb4a7316067208c389baca6.tar.bz2
packages-4dd20482570e1e3c3cb4a7316067208c389baca6.tar.xz
packages-4dd20482570e1e3c3cb4a7316067208c389baca6.zip
user/sg3_utils: new package
Diffstat (limited to 'user/sg3_utils')
-rw-r--r--user/sg3_utils/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/sg3_utils/APKBUILD b/user/sg3_utils/APKBUILD
new file mode 100644
index 000000000..7dc10d989
--- /dev/null
+++ b/user/sg3_utils/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=sg3_utils
+pkgver=1.44
+pkgrel=0
+pkgdesc="Utilities to manipulate SCSI devices"
+url="http://sg.danny.cz/sg/sg3_utils.html"
+arch="all"
+license="BSD-2-Clause AND GPL-2.0-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://sg.danny.cz/sg/p/sg3_utils-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4f4d5536ebed62f2c81c55741043d9ac3f4610a4dd6ef2e3125f041afd57aae03a32c2affe84a960c9f61fb6f84784bc901c756a8c36c1bc97082fa61e73ae8d sg3_utils-1.44.tar.xz"