summaryrefslogtreecommitdiff
path: root/user/skanlite/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-01 20:41:42 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-01 20:41:42 +0000
commit4c66fd861e536f7b7e2e68a78b748cfeb62026c4 (patch)
tree87c3a796971548386b7761b4a1f3d8b0c001e9d0 /user/skanlite/APKBUILD
parentfb133d320c064560942081ed07c783e1dffe9a50 (diff)
downloadpackages-4c66fd861e536f7b7e2e68a78b748cfeb62026c4.tar.gz
packages-4c66fd861e536f7b7e2e68a78b748cfeb62026c4.tar.bz2
packages-4c66fd861e536f7b7e2e68a78b748cfeb62026c4.tar.xz
packages-4c66fd861e536f7b7e2e68a78b748cfeb62026c4.zip
user/[KDE Graphics]: Bump to 19.12.0 (and Krita)
This bumps Krita to 4.2.8.2, the latest release. Also removes the Qt 5.9 compat patch for Spectacle.
Diffstat (limited to 'user/skanlite/APKBUILD')
-rw-r--r--user/skanlite/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/user/skanlite/APKBUILD b/user/skanlite/APKBUILD
index 77c06dc04..b639bc7a8 100644
--- a/user/skanlite/APKBUILD
+++ b/user/skanlite/APKBUILD
@@ -17,7 +17,6 @@ source="https://download.kde.org/stable/skanlite/2.1/skanlite-$pkgver.tar.xz
"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -28,17 +27,15 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}