summaryrefslogtreecommitdiff
path: root/user/skanlite
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-30 04:15:06 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-30 04:15:06 +0000
commit6c99bae4c71c2ee576ccaef661cedea5a652a9d3 (patch)
treece6f066032ccafa7a86318cb0500239f82965604 /user/skanlite
parentc4068760a6735db6c5b785827ccf2bb9f95eb25c (diff)
downloadpackages-6c99bae4c71c2ee576ccaef661cedea5a652a9d3.tar.gz
packages-6c99bae4c71c2ee576ccaef661cedea5a652a9d3.tar.bz2
packages-6c99bae4c71c2ee576ccaef661cedea5a652a9d3.tar.xz
packages-6c99bae4c71c2ee576ccaef661cedea5a652a9d3.zip
user/skanlite: Update to 2.2.0
Diffstat (limited to 'user/skanlite')
-rw-r--r--user/skanlite/APKBUILD10
-rw-r--r--user/skanlite/build.patch27
-rw-r--r--user/skanlite/fix-version.patch23
3 files changed, 32 insertions, 28 deletions
diff --git a/user/skanlite/APKBUILD b/user/skanlite/APKBUILD
index b639bc7a8..3aef76bc0 100644
--- a/user/skanlite/APKBUILD
+++ b/user/skanlite/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=skanlite
-pkgver=2.1.0.1
+pkgver=2.2.0
pkgrel=0
pkgdesc="Simple image scanning application"
url="https://www.kde.org/applications/graphics/skanlite/"
@@ -12,8 +12,8 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev libksane-dev kio-dev
kcoreaddons-dev ki18n-dev kxmlgui-dev kdoctools-dev libpng-dev zlib-dev
ktextwidgets-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/skanlite/2.1/skanlite-$pkgver.tar.xz
- fix-version.patch
+source="https://download.kde.org/stable/skanlite/2.2/skanlite-$pkgver.tar.xz
+ build.patch
"
build() {
@@ -39,5 +39,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="8eb1a32994259010d4a134c1b25b74b8cc03ba4fa6ce70ee2026a3070c675c2b11f38770453d197008fbe12df976cc653362eb44d6ef89a7f0173c3a2cef3658 skanlite-2.1.0.1.tar.xz
-91ce7a1f9a2796be511f20978fdea9e19c9eb6415ae5d407fbc855675d2e6809ddc85546b4e018ca0d72262d86104292c81e490613ae9045d10257e646da8732 fix-version.patch"
+sha512sums="cbf4c85894c742f025147950f1586252b92e0b3ad9f51b917649c449d46387a4673141e7645cd7f0b005b4c50dd671f2217d35e64ac84e97afa7a6562a961b20 skanlite-2.2.0.tar.xz
+38c2bd0f30af6a553840394fc341fff05d83af16db8b2c6385417d0b0759dd4fdacbe20d191b4bc3f65605e3c2e4101589c647986baabf2455ec33689289e5f2 build.patch"
diff --git a/user/skanlite/build.patch b/user/skanlite/build.patch
new file mode 100644
index 000000000..21d0e73bf
--- /dev/null
+++ b/user/skanlite/build.patch
@@ -0,0 +1,27 @@
+From b110846fadeb4f8fab48e0f488a335de7e16a7be Mon Sep 17 00:00:00 2001
+From: Wolfgang Bauer <wbauer@tmo.at>
+Date: Wed, 15 Jul 2020 09:11:43 +0000
+Subject: [PATCH] Fix compilation with Qt before 5.14
+
+This line has been forgotten to be changed in commit 823abcd2, resulting
+in a compiler error when e.g. building with Qt 5.12 LTS.
+---
+ src/SaveLocation.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/SaveLocation.cpp b/src/SaveLocation.cpp
+index 9709d49..d210be8 100644
+--- a/src/SaveLocation.cpp
++++ b/src/SaveLocation.cpp
+@@ -42,7 +42,7 @@ SaveLocation::SaveLocation(QWidget *parent)
+ connect(m_ui->u_urlRequester, &KUrlRequester::textChanged, this, &SaveLocation::updateGui);
+ connect(m_ui->u_imgPrefix, &QLineEdit::textChanged, this, &SaveLocation::updateGui);
+ #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
+- connect(u_imgFormat, static_cast<void (QComboBox::*)(const QString &)>(&QComboBox::activated), this, &SaveLocation::updateGui);
++ connect(m_ui->u_imgFormat, static_cast<void (QComboBox::*)(const QString &)>(&QComboBox::activated), this, &SaveLocation::updateGui);
+ #else
+ connect(m_ui->u_imgFormat, static_cast<void (QComboBox::*)(const QString &)>(&QComboBox::textActivated), this, &SaveLocation::updateGui);
+ #endif
+--
+GitLab
+
diff --git a/user/skanlite/fix-version.patch b/user/skanlite/fix-version.patch
deleted file mode 100644
index e5afa0be2..000000000
--- a/user/skanlite/fix-version.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- skanlite-2.0.1/CMakeLists.txt.old 2016-10-26 12:00:57.000000000 -0500
-+++ skanlite-2.0.1/CMakeLists.txt 2018-03-13 17:08:17.378028117 -0500
-@@ -43,7 +43,8 @@
-
- set(SKANLITE_VERSION_STRING "2.0.1")
-
--configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/version.h)
-+configure_file("${CMAKE_CURRENT_BINARY_DIR}/skanlite_version.h" "${CMAKE_CURRENT_BINARY_DIR}/src/version.h" COPYONLY)
-+#configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/version.h)
-
- find_package(KF5 ${KF5_VERSION} REQUIRED
- COMPONENTS # alias to find_package(KFGuiAddons ${KF5_VERSION} REQUIRED)
---- skanlite-2.0.1/src/main.cpp.old 2016-10-26 17:00:34.000000000 +0000
-+++ skanlite-2.0.1/src/main.cpp 2018-03-13 22:59:18.898057063 +0000
-@@ -44,7 +44,7 @@
-
- KAboutData aboutData(QLatin1String("Skanlite"), // componentName, k4: appName
- i18n("Skanlite"), // displayName, k4: programName
-- QLatin1String(skanlite_version), // version
-+ QLatin1String(SKANLITE_VERSION_STRING), // version
- i18n("Scanning application by KDE based on libksane."), // shortDescription
- KAboutLicense::GPL, // licenseType
- i18n("(C) 2008-2016 Kåre Särs"), // copyrightStatement