summaryrefslogtreecommitdiff
path: root/user/spack/clingo-explicit-libatomic.patch
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-12-07 21:34:52 +0000
committerZach van Rijn <me@zv.io>2024-12-07 17:34:47 -0600
commitbc7fcd1b36a697ab8ce5fd6ace425a9143330dce (patch)
treed2c4e1030b807eafeec9295ba671e3690c12dcbd /user/spack/clingo-explicit-libatomic.patch
parenta969dcc1cb523d61cc3cfd879100b352c8fd0e24 (diff)
downloadpackages-bc7fcd1b36a697ab8ce5fd6ace425a9143330dce.tar.gz
packages-bc7fcd1b36a697ab8ce5fd6ace425a9143330dce.tar.bz2
packages-bc7fcd1b36a697ab8ce5fd6ace425a9143330dce.tar.xz
packages-bc7fcd1b36a697ab8ce5fd6ace425a9143330dce.zip
user/spack: bump { 0.21.0 --> 0.23.0 }.
NOTE: packages built during the 'clingo-bootstrap' process no longer apply patches of the form 'patch("foo.patch")' due to changes noted at spack#16. Upstream is aware. v0.22.0 introduces libc awareness (currently glibc or musl). https://github.com/spack/spack/pull/43190 v0.23.0 removes the old concretizer, final 0.x release. https://github.com/spack/spack/pull/45215 v1.0.0 has high-impact changes. several compiler limitations. https://github.com/spack/spack/pull/45189 See also: https://github.com/spack/spack/discussions/30634
Diffstat (limited to 'user/spack/clingo-explicit-libatomic.patch')
-rw-r--r--user/spack/clingo-explicit-libatomic.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/user/spack/clingo-explicit-libatomic.patch b/user/spack/clingo-explicit-libatomic.patch
index 6a1d1a0aa..60bf83c5d 100644
--- a/user/spack/clingo-explicit-libatomic.patch
+++ b/user/spack/clingo-explicit-libatomic.patch
@@ -1,12 +1,12 @@
diff --git a/var/spack/repos/builtin/packages/clingo/package.py b/var/spack/repos/builtin/packages/clingo/package.py
-index ab5fe9a043..8a31208850 100644
+index 73ff2b1769..40c2c61dfc 100644
--- a/var/spack/repos/builtin/packages/clingo/package.py
+++ b/var/spack/repos/builtin/packages/clingo/package.py
-@@ -120,6 +120,7 @@ def cmake_args(self):
- "-DCLINGO_BUILD_WITH_PYTHON=ON",
- "-DPYCLINGO_USER_INSTALL=OFF",
- "-DPYCLINGO_USE_INSTALL_PREFIX=ON",
-+ "-DCMAKE_CXX_STANDARD_LIBRARIES=-latomic",
+@@ -118,6 +118,7 @@ def cmake_args(self):
+ self.define("PYCLINGO_USE_INSTALL_PREFIX", True),
+ self.define("PYCLINGO_INSTALL_DIR", python_platlib),
+ self.define("PYCLINGO_SUFFIX", suffix),
++ self.define("CMAKE_CXX_STANDARD_LIBRARIES", "-latomic"),
self.cmake_py_shared,
]
- if self.spec["cmake"].satisfies("@3.16.0:"):
+ else: