summaryrefslogtreecommitdiff
path: root/user/speexdsp
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-13 02:49:04 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-13 02:49:16 -0500
commitefa5ac2ac2713bd7f058486fcd86bcc1572a2bc4 (patch)
treea0b36250dc11f95ce7cbb6c7177320c439e7b62b /user/speexdsp
parent1e78a7b5661a3c11302066262cd250776c83c656 (diff)
downloadpackages-efa5ac2ac2713bd7f058486fcd86bcc1572a2bc4.tar.gz
packages-efa5ac2ac2713bd7f058486fcd86bcc1572a2bc4.tar.bz2
packages-efa5ac2ac2713bd7f058486fcd86bcc1572a2bc4.tar.xz
packages-efa5ac2ac2713bd7f058486fcd86bcc1572a2bc4.zip
user/speexdsp: pull in, fix up
Diffstat (limited to 'user/speexdsp')
-rw-r--r--user/speexdsp/APKBUILD48
-rw-r--r--user/speexdsp/speexdsp-fixbuilds-774c87d.patch36
2 files changed, 84 insertions, 0 deletions
diff --git a/user/speexdsp/APKBUILD b/user/speexdsp/APKBUILD
new file mode 100644
index 000000000..37aa29cd3
--- /dev/null
+++ b/user/speexdsp/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer:
+pkgname=speexdsp
+pkgver=1.2_rc3
+upstreamver=1.2rc3
+pkgrel=0
+pkgdesc="A voice compression format (DSP)"
+url="https://www.speex.org/"
+arch="all"
+options="!check" # No test suite.
+license="BSD-3-Clause"
+depends=""
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc"
+replaces="libspeex"
+source="https://downloads.xiph.org/releases/speex/$pkgname-$upstreamver.tar.gz
+ speexdsp-fixbuilds-774c87d.patch
+ "
+builddir="$srcdir"/$pkgname-$upstreamver
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ local _neon
+ cd "$builddir"
+ [ "$CARCH" = "aarch64" ] && _neon="--disable-neon"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static \
+ $_neon
+ make
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="29dfa8345df025eeb076561648a9b5c0485692be699b6da3c2a3734b4329187a1c2eb181252f4df12b21f1309ecdf59797437dfb123d160fd723491ab216e858 speexdsp-1.2rc3.tar.gz
+0f0c8054591915a4ea06b28b13d50da41be10d594f39a0496e2e80e4514ed53db7cd0e1fdb205ce5e87f602b9c1e15409c33cf946ab25cdef8a3b147dbfcc0f3 speexdsp-fixbuilds-774c87d.patch"
diff --git a/user/speexdsp/speexdsp-fixbuilds-774c87d.patch b/user/speexdsp/speexdsp-fixbuilds-774c87d.patch
new file mode 100644
index 000000000..c02ee29bd
--- /dev/null
+++ b/user/speexdsp/speexdsp-fixbuilds-774c87d.patch
@@ -0,0 +1,36 @@
+diff --git a/configure.ac b/configure.ac
+index 2cd2d1e..1de0c23 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -334,6 +334,12 @@ AC_SUBST([USIZE16])
+ AC_SUBST([SIZE32])
+ AC_SUBST([USIZE32])
+
++AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
++ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
++ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
++
++AC_SUBST([INCLUDE_STDINT])
++
+ AC_CONFIG_FILES([
+ Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
+ include/Makefile include/speex/Makefile speexdsp.pc
+diff --git a/include/speex/speexdsp_config_types.h.in b/include/speex/speexdsp_config_types.h.in
+index 02b82fd..5ea7b55 100644
+--- a/include/speex/speexdsp_config_types.h.in
++++ b/include/speex/speexdsp_config_types.h.in
+@@ -1,13 +1,7 @@
+ #ifndef __SPEEX_TYPES_H__
+ #define __SPEEX_TYPES_H__
+
+-#if defined HAVE_STDINT_H
+-# include <stdint.h>
+-#elif defined HAVE_INTTYPES_H
+-# include <inttypes.h>
+-#elif defined HAVE_SYS_TYPES_H
+-# include <sys/types.h>
+-#endif
++@INCLUDE_STDINT@
+
+ typedef @SIZE16@ spx_int16_t;
+ typedef @USIZE16@ spx_uint16_t;