summaryrefslogtreecommitdiff
path: root/user/spice-gtk
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-06-15 03:23:30 -0500
committerMax Rees <maxcrees@me.com>2020-06-15 03:23:30 -0500
commit835f7458c8a776f8554ff9e9b0adb888bd2271ac (patch)
tree1085458c3343e8370226366ad719da29cb03f6f3 /user/spice-gtk
parent18c6e5665fe1dadc47fad19f3f9629a5f9040b2b (diff)
downloadpackages-835f7458c8a776f8554ff9e9b0adb888bd2271ac.tar.gz
packages-835f7458c8a776f8554ff9e9b0adb888bd2271ac.tar.bz2
packages-835f7458c8a776f8554ff9e9b0adb888bd2271ac.tar.xz
packages-835f7458c8a776f8554ff9e9b0adb888bd2271ac.zip
user/spice-gtk: switch coroutine impl from ucontext to gthread
Fixes a failure on ppc32: 8/12 spice-gtk / test-coroutine FAIL 0.02 s (killed by signal 6 SIGABRT) --- command --- /usr/src/packages/user/spice-gtk/src/spice-gtk-0.38/output/tests/test-coroutine --- stdout --- # random seed: R02S414e77a117fac2e9cd10eee9a9f61d84 1..3 # Start of coroutine tests Bail out! GSpice:ERROR:../tests/coroutine.c:37:test_coroutine_simple: assertion failed (GPOINTER_TO_INT(result) == 0x42): (0 == 66) --- stderr --- ** GSpice:ERROR:../tests/coroutine.c:37:test_coroutine_simple: assertion failed (GPOINTER_TO_INT(result) == 0x42): (0 == 66) -------
Diffstat (limited to 'user/spice-gtk')
-rw-r--r--user/spice-gtk/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/spice-gtk/APKBUILD b/user/spice-gtk/APKBUILD
index fb44cc0ec..e8a558036 100644
--- a/user/spice-gtk/APKBUILD
+++ b/user/spice-gtk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=spice-gtk
pkgver=0.38
-pkgrel=0
+pkgrel=1
pkgdesc="A GTK+ widget for SPICE clients"
url="https://www.spice-space.org/"
arch="all"
@@ -13,7 +13,7 @@ depends="gst-plugins-good"
depends_dev="gobject-introspection-dev gtk+3.0-dev"
makedepends="$depends_dev acl-dev bash cyrus-sasl-dev eudev-dev
gst-plugins-base-dev gstreamer-dev gstreamer-tools gtk-doc
- json-glib-dev libjpeg-turbo-dev libucontext-dev
+ json-glib-dev libjpeg-turbo-dev
libxrandr-dev lz4-dev meson openssl-dev opus-dev polkit-dev
py3-pyparsing py3-six spice-protocol
zlib-dev"
@@ -24,8 +24,6 @@ source="https://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.xz
"
build() {
- export CFLAGS="$CFLAGS -lucontext"
-
# Note: pulseaudio support is disabled because it's deprecated.
# Audio is still supported through gstreamer.
#
@@ -41,6 +39,7 @@ build() {
-Dcelt051=disabled \
-Dpulse=disabled \
-Dusbredir=disabled \
+ -Dcoroutine=gthread \
. output
ninja -C output
}