summaryrefslogtreecommitdiff
path: root/user/supertux
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-23 01:55:36 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-23 01:55:36 +0000
commit1aba9b49628690490b7e965c93d035469b5c9eb8 (patch)
treea718a7ec76e16a4e02047d03bc5b8f8dc9eb7308 /user/supertux
parent5839fb7eaa4265eb7dbd6a01aa6443fdf71fb7dc (diff)
downloadpackages-1aba9b49628690490b7e965c93d035469b5c9eb8.tar.gz
packages-1aba9b49628690490b7e965c93d035469b5c9eb8.tar.bz2
packages-1aba9b49628690490b7e965c93d035469b5c9eb8.tar.xz
packages-1aba9b49628690490b7e965c93d035469b5c9eb8.zip
user/supertux: New package
Diffstat (limited to 'user/supertux')
-rw-r--r--user/supertux/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/user/supertux/APKBUILD b/user/supertux/APKBUILD
new file mode 100644
index 000000000..5b313064a
--- /dev/null
+++ b/user/supertux/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=supertux
+pkgver=0.6.2
+pkgrel=0
+pkgdesc="Platform game featuring Tux the Penugin"
+url="https://www.supertux.org/"
+arch="all"
+license="GPL-3.0+"
+depends=""
+makedepends="boost-dev cmake curl-dev glew-dev libogg-dev libvorbis-dev
+ mesa-dev openal-soft-dev physfs-dev sdl2-dev sdl2_image-dev doxygen"
+subpackages="$pkgname-doc"
+source="https://github.com/SuperTux/supertux/releases/download/v$pkgver/SuperTux-v$pkgver-Source.tar.gz"
+builddir="$srcdir"/SuperTux-v$pkgver-Source
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS} \
+ .
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5baa783ee589b42a9bbce3740659dbb7b617ebfcc00c0a038c03d31b56700e3923c8548700ccebe42b325ca03bd85186bc5edef9f6580d93dc48d8aca88cbf74 SuperTux-v0.6.2-Source.tar.gz"