summaryrefslogtreecommitdiff
path: root/user/talloc
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-04-18 00:59:53 -0400
committerMax Rees <maxcrees@me.com>2019-04-18 05:02:53 -0400
commit93a7c7d3b91491b3b91d3d0a4750167644aaeeb1 (patch)
tree6de6f99aa59db86ec7d7ead94bc0e0619975205e /user/talloc
parenta80feef24bc8bb7a16975a459b04d0d431f0658c (diff)
downloadpackages-93a7c7d3b91491b3b91d3d0a4750167644aaeeb1.tar.gz
packages-93a7c7d3b91491b3b91d3d0a4750167644aaeeb1.tar.bz2
packages-93a7c7d3b91491b3b91d3d0a4750167644aaeeb1.tar.xz
packages-93a7c7d3b91491b3b91d3d0a4750167644aaeeb1.zip
user/talloc: bump to 2.2.0
Diffstat (limited to 'user/talloc')
-rw-r--r--user/talloc/APKBUILD13
-rw-r--r--user/talloc/waf-location.patch10
2 files changed, 4 insertions, 19 deletions
diff --git a/user/talloc/APKBUILD b/user/talloc/APKBUILD
index 82ba9d682..bf6cb12c8 100644
--- a/user/talloc/APKBUILD
+++ b/user/talloc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=talloc
-pkgver=2.1.15
+pkgver=2.2.0
pkgrel=0
pkgdesc="Memory pool management library"
url="https://talloc.samba.org"
@@ -9,13 +9,11 @@ arch="all"
license="LGPL-3.0+ AND GPL-3.0+ AND ISC AND LGPL-2.1+ AND BSD-3-Clause AND PostgreSQL"
replaces="samba-common"
depends=""
-makedepends="docbook-xsl libxslt python3-dev"
+makedepends="cmd:which docbook-xsl libxslt python3-dev"
subpackages="$pkgname-dev py3-$pkgname:py3 $pkgname-doc"
-source="https://samba.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz
- waf-location.patch"
+source="https://samba.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
PYTHON=python3 ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -49,5 +45,4 @@ py3() {
"$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
}
-sha512sums="41896f8877e9a52e70b9881c41667dc52d7c1b03c3b248020fd909b794a4c5a4addee3eb944aa80ecfa3b03e6e5e1f67a62b5f3a5dcdc412b3e975352057ff40 talloc-2.1.15.tar.gz
-d19553fae679b5db10ab77a86f9fa0525ccba37a3ef30e530cd96245ee5fc94d4570079bbfe0271c32fbc84a3556c4bf86cc1cab6ffb61863cbce3f5a911efec waf-location.patch"
+sha512sums="e762c6443ff2c0c35a9dbf7ac6e64a9182c04a218ad0f26fd67ac9620d9ae26d68b8dd2b21ff37e1df0e53748c84bece27890c5c4939eaeb61c502a698802388 talloc-2.2.0.tar.gz"
diff --git a/user/talloc/waf-location.patch b/user/talloc/waf-location.patch
deleted file mode 100644
index a5ca47f44..000000000
--- a/user/talloc/waf-location.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- talloc-2.1.15/Makefile 2019-01-14 17:24:45.000000000 -0500
-+++ talloc-2.1.15/Makefile 2019-01-27 22:57:15.919981283 -0500
-@@ -1,6 +1,6 @@
- # simple makefile wrapper to run waf
-
--WAF_BINARY=$(PYTHON) ../../buildtools/bin/waf
-+WAF_BINARY=$(PYTHON) buildtools/bin/waf
- WAF=PYTHONHASHSEED=1 WAF_MAKE=1 $(WAF_BINARY)
-
- all: