summaryrefslogtreecommitdiff
path: root/user/tcsh/APKBUILD
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-27 22:42:20 -0700
committerDan Theisen <djt@hxx.in>2018-09-27 22:42:20 -0700
commit1af97d0c4495ab4d323538fa3f86c26f3b063efb (patch)
tree330a2478caf47b93eb5a77d8c363e1092b11a7ea /user/tcsh/APKBUILD
parenta9317a57f10e562a57e3a964868688aef8a70129 (diff)
downloadpackages-1af97d0c4495ab4d323538fa3f86c26f3b063efb.tar.gz
packages-1af97d0c4495ab4d323538fa3f86c26f3b063efb.tar.bz2
packages-1af97d0c4495ab4d323538fa3f86c26f3b063efb.tar.xz
packages-1af97d0c4495ab4d323538fa3f86c26f3b063efb.zip
user/tcsh: new package
Diffstat (limited to 'user/tcsh/APKBUILD')
-rw-r--r--user/tcsh/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/user/tcsh/APKBUILD b/user/tcsh/APKBUILD
new file mode 100644
index 000000000..2fdfac0b2
--- /dev/null
+++ b/user/tcsh/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=tcsh
+pkgver=6.20.00
+pkgrel=2
+pkgdesc="extended C-shell"
+url="http://www.tcsh.org"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+checkdepends="diffutils autoconf"
+makedepends="ncurses-dev ncurses-terminfo utmps-dev gettext-tiny-dev"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
+subpackages="$pkgname-doc"
+options="!checkroot"
+source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/t/tcsh/${pkgname}_${pkgver}.orig.tar.gz
+ 001-sysmalloc.patch
+ 002-test_123-posix_fix.patch"
+
+build() {
+ cd "$builddir"
+ LIBS="-lutmps -lskarnet -ltinfo" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --bindir=/bin \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-nls \
+ --enable-nls-catalogs \
+ --disable-rpath
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz
+40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch
+b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch"