summaryrefslogtreecommitdiff
path: root/user/tcsh
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2019-06-25 10:23:44 +0000
committerDan Theisen <djt@hxx.in>2019-06-25 10:58:45 +0000
commit2af1f69eebb969d3d10275e0448bb3592b2f4a87 (patch)
treee6e2883536791c12963999576f0761612c7085fd /user/tcsh
parentf8bfd713b064991dfc46cbb7817829315932af67 (diff)
downloadpackages-2af1f69eebb969d3d10275e0448bb3592b2f4a87.tar.gz
packages-2af1f69eebb969d3d10275e0448bb3592b2f4a87.tar.bz2
packages-2af1f69eebb969d3d10275e0448bb3592b2f4a87.tar.xz
packages-2af1f69eebb969d3d10275e0448bb3592b2f4a87.zip
user/tcsh: bump to 6.21.00
Diffstat (limited to 'user/tcsh')
-rw-r--r--user/tcsh/002-test_123-posix_fix.patch34
-rw-r--r--user/tcsh/APKBUILD19
2 files changed, 10 insertions, 43 deletions
diff --git a/user/tcsh/002-test_123-posix_fix.patch b/user/tcsh/002-test_123-posix_fix.patch
deleted file mode 100644
index 6ed59de38..000000000
--- a/user/tcsh/002-test_123-posix_fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Author: Dan Theisen <djt@hxx.in>
-Date: Wed Jun 06 03:30:25 2018 -0800
-
-The following lines have a subtle change around [:blank:], changing it
-to [[:blank:]] instead. This is required because POSIX treats characters
-inside of brackets as a group of characters to match against. In this case,
-[[:space:]] means [] group of characters, and [:space:] is the group, as per:
-IEEE Std 1003.1-2017 (Revision of IEEE Std 1003.1-2008), Chapter 9
-http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap09.html
-
---- tcsh-6.20.00/tests/lexical.at.old 2018-06-06 02:20:16.787145186 -0700
-+++ tcsh-6.20.00/tests/lexical.at 2018-06-06 02:21:09.537890842 -0700
-@@ -567,10 +567,10 @@
- ]])
- AT_DATA([uniformity_test.csh],
- [[
--set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
-+set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
- echo -n "$SERVICE_NAME_LOG" > ./output1
-
--cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
-+cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
-
- diff -uprN ./output1 ./output2 >& /dev/null
-
-@@ -587,7 +587,7 @@
- echo "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP\)(HOST=db\)(PORT=1521\)\)(CONNECT_DATA=(SERVER=DEDICATED\)(SERVICE_NAME=bns03\)\)\)" > ./expected_result
-
- set string = "jdbc_url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=db)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=bns03)))"
--set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
-+set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
-
- echo "$SERVICE_NAME_LOG" > ./actual_result
-
diff --git a/user/tcsh/APKBUILD b/user/tcsh/APKBUILD
index 2fdfac0b2..ee876adff 100644
--- a/user/tcsh/APKBUILD
+++ b/user/tcsh/APKBUILD
@@ -1,10 +1,12 @@
# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=tcsh
-pkgver=6.20.00
-pkgrel=2
+pkgver=6.21.00
+_pkgver=${pkgver%.*.*}_${pkgver#*.}
+_pkgver=${_pkgver%.*}_${_pkgver#*.}
+pkgrel=0
pkgdesc="extended C-shell"
-url="http://www.tcsh.org"
+url="https://www.tcsh.org"
arch="all"
license="BSD-3-Clause"
depends=""
@@ -13,10 +15,10 @@ makedepends="ncurses-dev ncurses-terminfo utmps-dev gettext-tiny-dev"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
options="!checkroot"
-source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/t/tcsh/${pkgname}_${pkgver}.orig.tar.gz
- 001-sysmalloc.patch
- 002-test_123-posix_fix.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tcsh-org/tcsh/archive/TCSH${_pkgver}.tar.gz
+ 001-sysmalloc.patch"
+builddir="$srcdir/${pkgname}-TCSH${_pkgver}"
build() {
cd "$builddir"
LIBS="-lutmps -lskarnet -ltinfo" ./configure \
@@ -42,6 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz
-40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch
-b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch"
+sha512sums="305380fd065ca4703ffba002358b41727056481573a78301cb8c2390d5fe1a4107af5d482db5abf26f0ce9f7193c8aeb0e34fedcc40971499be2e6dc13bf3405 tcsh-6.21.00.tar.gz
+40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch"